SimpleSAMLphp Use of insecure connection charset (sqlauth module)
The advisory, in context
The sqlauth module in SimpleSAMLphp before 1.15.2 relies on the MySQL utf8 charset, which truncates queries upon encountering four-byte characters. There might be a scenario in which this allows remote attackers to bypass intended access restrictions.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 1.15.2
Fixed in 1.15.2
30 explicitly affected versions
v1.12.0, v1.13.0, v1.13.0-rc1, v1.13.0-rc2, v1.13.1, v1.13.2, v1.14.0, v1.14.0-rc1, v1.14.1, v1.14.10, v1.14.11, v1.14.12, v1.14.13, v1.14.14, v1.14.15, v1.14.16, v1.14.17, v1.14.2, v1.14.3, v1.14.4, v1.14.5, v1.14.6, v1.14.7, v1.14.8, v1.14.9, v1.15.0, v1.15.0-rc1, v1.15.0-rc2, v1.15.0-rc3, v1.15.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.15.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v1.12.0",
"v1.13.0",
"v1.13.0-rc1",
"v1.13.0-rc2",
"v1.13.1",
"v1.13.2",
"v1.14.0",
"v1.14.0-rc1",
"v1.14.1",
"v1.14.10",
"v1.14.11",
"v1.14.12",
"v1.14.13",
"v1.14.14",
"v1.14.15",
"v1.14.16",
"v1.14.17",
"v1.14.2",
"v1.14.3",
"v1.14.4",
"v1.14.5",
"v1.14.6",
"v1.14.7",
"v1.14.8",
"v1.14.9",
"v1.15.0",
"v1.15.0-rc1",
"v1.15.0-rc2",
"v1.15.0-rc3",
"v1.15.1"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2018-6521
- https://github.com/FriendsOfPHP/security-advisories/blob/master/simplesamlphp/simplesamlphp/CVE-2018-6521.yaml
- https://github.com/simplesamlphp/simplesamlphp
- https://lists.debian.org/debian-lts-announce/2018/02/msg00008.html
- https://simplesamlphp.org/security/201801-03
- https://www.debian.org/security/2018/dsa-4127