GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GHSA-qrxm-fqhp-jwvmhigh7.5

undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation

Check your stack

The advisory, in context

Impact

undici crashes the client process when a TLS 1.2 server renegotiates after the connection is established and presents a different, CA-trusted certificate whose hostname does not match the requested host. Node.js re-runs hostname verification on the renegotiated handshake and destroys the socket with ERR_TLS_CERT_ALTNAME_INVALID. undici's established socket error handler asserted that this error code could never occur, so the peer-controlled error became an uncaught AssertionError that terminates the Node.js process. Both the HTTP/1.1 and HTTP/2 paths are affected.

A malicious or compromised HTTPS endpoint reached through undici or the global fetch() can crash the client with a single server-initiated renegotiation, taking down all in-flight requests and background work in the process. Only TLS 1.2 is affected, because TLS 1.3 does not support renegotiation. Exploitation does not require a CA compromise: the attacker controls the endpoint and can present two ordinary valid certificates, the first matching the requested URL and the second intentionally not matching it.

Patches

Upgrade to undici 6.29.1, 7.30.1, or 8.12.2.

Workarounds

Restrict outbound connections to TLS 1.3, for example by setting connect: { minVersion: 'TLSv1.3', maxVersion: 'TLSv1.3' } on the client or agent, so that renegotiation cannot occur, when the target endpoints support TLS 1.3.

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Semantic versions

From 4.2.1 before 6.29.1

Fixed in 6.29.1

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "4.2.1"
        },
        {
          "fixed": "6.29.1"
        }
      ],
      "type": "SEMVER"
    }
  ],
  "versions": []
}
Semantic versions

From 7.0.0 before 7.30.1

Fixed in 7.30.1

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "7.0.0"
        },
        {
          "fixed": "7.30.1"
        }
      ],
      "type": "SEMVER"
    }
  ],
  "versions": []
}
Semantic versions

From 8.0.0 before 8.12.2

Fixed in 8.12.2

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "8.0.0"
        },
        {
          "fixed": "8.12.2"
        }
      ],
      "type": "SEMVER"
    }
  ],
  "versions": []
}

References