Awesome Support vulnerable to persistent cross-site scripting
The advisory, in context
Multiple Authenticated (custom specific plugin role) Persistent Cross-Site Scripting (XSS) vulnerability in Awesome Support plugin <= 6.0.7 at WordPress.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 6.0.8
Fixed in 6.0.8
105 explicitly affected versions
3.0.0, 3.0.0-beta-1, 3.0.0-beta-2, 3.0.1, 3.1.0, 3.1.1, 3.1.10, 3.1.11, 3.1.12, 3.1.2, 3.1.3, 3.1.5, 3.1.6, 3.1.7, 3.1.8, 3.1.9, 3.2.0, 3.2.1, 3.2.2, 3.2.3, 3.2.4, 3.2.5, 3.2.6, 3.2.8, 3.2.9, 3.3.0, 3.3.1, 3.3.2, 3.3.3, 3.3.4, 3.3.4_RC01, 3.3.4_RC02, 3.3.4_RC03, 3.3.4_RC05, 3.4.0_RC01, 3.6.0_RC01, 3.6.0_RC02, 3.6.0_RC04, 3.6.0_RC05, 4.0.0, 4.0.0_RC01, 4.0.0_RC02, 4.0.0_RC03, 4.0.0_RC04, 4.0.0_RC05, 4.0.0_RC06, 4.0.0_RC07, 4.0.0_RC08, 4.0.0_RC09, 4.0.0_RC10, 4.0.0_RC11, 4.0.2, 4.0.3, 4.0.4, 4.0.5, 4.0.5_RC01, 4.0.5_RC02, 4.0.5_RC03, 4.0.5_RC04, 4.0.6, 4.1.0, 4.2.0, 4.2.1, 4.3.0, 4.3.1, 4.3.2, 4.3.4, 4.3.5, 4.4.0_RC01, 4.4.0_RC02, 4.4.0_RC03, 4.4.0_RC04, 4.4.0_RC05, 4.4.0_RC06, 4.4.0_RC07, 4.4.0_RC08, 4.4.0_RC09, 4.4.0_RC10, 4.4.0_RC11, 4.4.0_RC12, 5.0.0, 5.1.0, 5.1.1, 5.2.0_RC11, 5.2.0_RC13, 5.2.0_RC14, 5.2.0_RC16, 5.2.0_RC17, 5.2.0_RC18, 5.2.0_RC19, 5.2.0_RC20, 5.2.0_RC21, 5.2_RC10, 5.5.0, 5.5.1, 5.5.2, 5.6.0, 5.7.0, 5.7.1, 5.8.0, 6.0.0, 6.0.1, 6.0.5, 6.0.6, 6.0.7
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "6.0.8"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"3.0.0",
"3.0.0-beta-1",
"3.0.0-beta-2",
"3.0.1",
"3.1.0",
"3.1.1",
"3.1.10",
"3.1.11",
"3.1.12",
"3.1.2",
"3.1.3",
"3.1.5",
"3.1.6",
"3.1.7",
"3.1.8",
"3.1.9",
"3.2.0",
"3.2.1",
"3.2.2",
"3.2.3",
"3.2.4",
"3.2.5",
"3.2.6",
"3.2.8",
"3.2.9",
"3.3.0",
"3.3.1",
"3.3.2",
"3.3.3",
"3.3.4",
"3.3.4_RC01",
"3.3.4_RC02",
"3.3.4_RC03",
"3.3.4_RC05",
"3.4.0_RC01",
"3.6.0_RC01",
"3.6.0_RC02",
"3.6.0_RC04",
"3.6.0_RC05",
"4.0.0",
"4.0.0_RC01",
"4.0.0_RC02",
"4.0.0_RC03",
"4.0.0_RC04",
"4.0.0_RC05",
"4.0.0_RC06",
"4.0.0_RC07",
"4.0.0_RC08",
"4.0.0_RC09",
"4.0.0_RC10",
"4.0.0_RC11",
"4.0.2",
"4.0.3",
"4.0.4",
"4.0.5",
"4.0.5_RC01",
"4.0.5_RC02",
"4.0.5_RC03",
"4.0.5_RC04",
"4.0.6",
"4.1.0",
"4.2.0",
"4.2.1",
"4.3.0",
"4.3.1",
"4.3.2",
"4.3.4",
"4.3.5",
"4.4.0_RC01",
"4.4.0_RC02",
"4.4.0_RC03",
"4.4.0_RC04",
"4.4.0_RC05",
"4.4.0_RC06",
"4.4.0_RC07",
"4.4.0_RC08",
"4.4.0_RC09",
"4.4.0_RC10",
"4.4.0_RC11",
"4.4.0_RC12",
"5.0.0",
"5.1.0",
"5.1.1",
"5.2.0_RC11",
"5.2.0_RC13",
"5.2.0_RC14",
"5.2.0_RC16",
"5.2.0_RC17",
"5.2.0_RC18",
"5.2.0_RC19",
"5.2.0_RC20",
"5.2.0_RC21",
"5.2_RC10",
"5.5.0",
"5.5.1",
"5.5.2",
"5.6.0",
"5.7.0",
"5.7.1",
"5.8.0",
"6.0.0",
"6.0.1",
"6.0.5",
"6.0.6",
"6.0.7"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2022-38073
- https://github.com/Awesome-Support/Awesome-Support/commit/85f460be88b81fbdd9a990f474a1252297902faf
- https://github.com/Awesome-Support/Awesome-Support/commit/b2e831d7f831a3869cfd83eb79a398a5b5c0ec63
- https://github.com/Awesome-Support/Awesome-Support
- https://patchstack.com/database/vulnerability/awesome-support/wordpress-awesome-support-plugin-6-0-7-multiple-authenticated-stored-cross-site-scripting-xss-vulnerabilities
- https://wordpress.org/plugins/awesome-support/#developers