GHSA-qrhq-x7xh-2784medium6.1
Froala WYSIWYG Editor XSS Vulnerability
The advisory, in context
Froala Editor before 3.2.2 allows XSS via pasted content.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
froala/wysiwyg-editor Packagist
Ecosystem versions
Earlier releases before 3.2.2
Fixed in 3.2.2
51 explicitly affected versions
2.7.1, v2.3.5, v2.4.0, v2.4.0-rc.1, v2.4.1, v2.4.2, v2.5.0, v2.5.1, v2.6.0, v2.6.1, v2.6.2, v2.6.3, v2.6.4, v2.6.5, v2.6.6, v2.7.0, v2.7.2, v2.7.3, v2.7.4, v2.7.5, v2.7.6, v2.8.0, v2.8.1, v2.8.2, v2.8.3, v2.8.4, v2.8.5, v2.9.0, v2.9.1, v2.9.2, v2.9.3, v2.9.4, v2.9.5, v2.9.6, v2.9.7, v2.9.8, v3.0.0, v3.0.0-beta.1, v3.0.0-beta.2, v3.0.0-rc.1, v3.0.0-rc.2, v3.0.1, v3.0.2, v3.0.3, v3.0.4, v3.0.5, v3.0.6, v3.1.0, v3.1.1, v3.2.0, v3.2.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "3.2.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.7.1",
"v2.3.5",
"v2.4.0",
"v2.4.0-rc.1",
"v2.4.1",
"v2.4.2",
"v2.5.0",
"v2.5.1",
"v2.6.0",
"v2.6.1",
"v2.6.2",
"v2.6.3",
"v2.6.4",
"v2.6.5",
"v2.6.6",
"v2.7.0",
"v2.7.2",
"v2.7.3",
"v2.7.4",
"v2.7.5",
"v2.7.6",
"v2.8.0",
"v2.8.1",
"v2.8.2",
"v2.8.3",
"v2.8.4",
"v2.8.5",
"v2.9.0",
"v2.9.1",
"v2.9.2",
"v2.9.3",
"v2.9.4",
"v2.9.5",
"v2.9.6",
"v2.9.7",
"v2.9.8",
"v3.0.0",
"v3.0.0-beta.1",
"v3.0.0-beta.2",
"v3.0.0-rc.1",
"v3.0.0-rc.2",
"v3.0.1",
"v3.0.2",
"v3.0.3",
"v3.0.4",
"v3.0.5",
"v3.0.6",
"v3.1.0",
"v3.1.1",
"v3.2.0",
"v3.2.1"
]
}