GHSA-qr97-v87p-x965critical9.8
Ariadne Component Library vulnerable to Server-Side Request Forgery
The advisory, in context
A vulnerability was found in Ariadne Component Library up to 2.x. It has been classified as critical. Affected is an unknown function of the file src/url/Url.php. The manipulation leads to server-side request forgery. Upgrading to version 3.0 can address this issue. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217140.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
arc/web Packagist
Ecosystem versions
Earlier releases before 3.0
Fixed in 3.0
6 explicitly affected versions
1.0, 1.0.1, 1.0.2, 1.1, 2.0, 2.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "3.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.0",
"1.0.1",
"1.0.2",
"1.1",
"2.0",
"2.1"
]
}