GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GHSA-qr95-4mq5-r3fhhigh7.7

Phar unserialization vulnerability in phpMussel

Check your stack

The advisory, in context

Impact

What kind of vulnerability is it? Who is impacted?

Anyone using >= v1.0.0 < v1.6.0.

Patches

Has the problem been patched? What versions should users upgrade to?

Yes. Upgrading to at least >= v1.6.0 (the earliest safe version) will resolve the problem. However, as multiple new major versions have been released since that version, upgrading to the latest available version is recommended, in order to protect against any potential future vulnerabilities, unknown at the time of writing this advisory.

Workarounds

Is there a way for users to fix or remediate the vulnerability without upgrading?

Yes. In the package's configuration, disable archive checking by setting check_archives to false (thus avoiding execution of the affected parts of the codebase entirely).

References

Are there any links users can visit to find out more?

Yes. The vulnerability is documented at SECURITY.md and also at #167.

For more information

If you have any questions or comments about this advisory:

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Ecosystem versions

From 1.0.0 before 1.6.0

Fixed in 1.6.0

7 explicitly affected versions

v1.0.0, v1.1.0, v1.2.0, v1.3.0, v1.3.1, v1.4.0, v1.5.0

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "1.0.0"
        },
        {
          "fixed": "1.6.0"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "v1.0.0",
    "v1.1.0",
    "v1.2.0",
    "v1.3.0",
    "v1.3.1",
    "v1.4.0",
    "v1.5.0"
  ]
}
Ecosystem versions

From 1.0.0 before 1.6.0

Fixed in 1.6.0

7 explicitly affected versions

v1.0.0, v1.1.0, v1.2.0, v1.3.0, v1.3.1, v1.4.0, v1.5.0

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "1.0.0"
        },
        {
          "fixed": "1.6.0"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "v1.0.0",
    "v1.1.0",
    "v1.2.0",
    "v1.3.0",
    "v1.3.1",
    "v1.4.0",
    "v1.5.0"
  ]
}

References