GHSA-qm4x-ch5w-gr62high
XXE in SabreDAV
The advisory, in context
SabreDAV before 1.7.11, as used in ownCloud Server before 5.0.15 and 6.0.x before 6.0.2, allows remote attackers to read arbitrary files, cause a denial of service, or possibly have other impact via an XML External Entity (XXE) attack.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
sabre/dav Packagist
Ecosystem versions
From 1.6.0 before 1.7.11
Fixed in 1.7.11
22 explicitly affected versions
1.6.0, 1.6.1, 1.6.10, 1.6.2, 1.6.3, 1.6.4, 1.6.5, 1.6.6, 1.6.7, 1.6.8, 1.6.9, 1.7.0, 1.7.1, 1.7.10, 1.7.2, 1.7.3, 1.7.4, 1.7.5, 1.7.6, 1.7.7, 1.7.8, 1.7.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.6.0"
},
{
"fixed": "1.7.11"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.6.0",
"1.6.1",
"1.6.10",
"1.6.2",
"1.6.3",
"1.6.4",
"1.6.5",
"1.6.6",
"1.6.7",
"1.6.8",
"1.6.9",
"1.7.0",
"1.7.1",
"1.7.10",
"1.7.2",
"1.7.3",
"1.7.4",
"1.7.5",
"1.7.6",
"1.7.7",
"1.7.8",
"1.7.9"
]
}sabre/dav Packagist
Ecosystem versions
From 1.8.0 before 1.8.9
Fixed in 1.8.9
9 explicitly affected versions
1.8.0, 1.8.1, 1.8.2, 1.8.3, 1.8.4, 1.8.5, 1.8.6, 1.8.7, 1.8.8
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.8.0"
},
{
"fixed": "1.8.9"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.8.0",
"1.8.1",
"1.8.2",
"1.8.3",
"1.8.4",
"1.8.5",
"1.8.6",
"1.8.7",
"1.8.8"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2014-2055
- https://github.com/sabre-io/dav/issues/414
- https://github.com/sabre-io/dav/commit/e3f46e0ecf83cf1d2ebf54908cde7b5ec170aa2c
- https://github.com/FriendsOfPHP/security-advisories/blob/master/sabre/dav/CVE-2014-2055.yaml
- https://github.com/fruux/sabre-dav/releases/tag/1.7.11