GHSA-qjjq-rcq8-jw6jmedium
Elefant CMS Multiple XSS Vulnerabilities
The advisory, in context
Multiple cross-site scripting (XSS) vulnerabilities in apps/admin/handlers/preview.php in Elefant CMS 1.0.x before 1.0.2-Beta and 1.1.x before 1.1.5-Beta allow remote attackers to inject arbitrary web script or HTML via the (1) title or (2) body parameter to admin/preview.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
elefant/cms Packagist
Ecosystem versions
From 1.0 before 1.0.2-Beta
Fixed in 1.0.2-Beta
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.0"
},
{
"fixed": "1.0.2-Beta"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}elefant/cms Packagist
Ecosystem versions
From 1.1 before 1.1.5-Beta
Fixed in 1.1.5-Beta
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.1"
},
{
"fixed": "1.1.5-Beta"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}References
- https://nvd.nist.gov/vuln/detail/CVE-2012-1296
- https://github.com/jbroadway/elefant/commit/1e38b1d91d9f8bfb4a0cda8316fe763a6cdd31d0
- https://github.com/jbroadway/elefant/commit/4fc4e0a704f697e593be927a447ca12b2863ff85
- https://exchange.xforce.ibmcloud.com/vulnerabilities/73421
- https://github.com/jbroadway/elefant
- https://web.archive.org/web/20120306001248/http://www.elefantcms.com/forum/discussion/39/elefant-1.0.2-and-1.1.5-security-updates-released
- https://web.archive.org/web/20200229030623/http://www.securityfocus.com/bid/52143