GHSA-qjhr-c23f-w76qmedium6.1
Inline JS XSS vulnerability in Mautic
Impact
Mautic version 2.1.0 - 2.11.0 is vulnerable to an inline JS XSS attack when using Mautic forms on a Mautic landing page using GET parameters to pre-populate the form.
Source excerpt · OSVAffected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
mautic/core Packagist
| Affected range | Recorded fix |
|---|---|
| From 2.1.0 before 2.12.0Ecosystem versions | 2.12.0 |
Version evidence: OSV · GHSA-qjhr-c23f-w76q
View original version evidence (25 explicit versions)
Original source description
Impact
Mautic version 2.1.0 - 2.11.0 is vulnerable to an inline JS XSS attack when using Mautic forms on a Mautic landing page using GET parameters to pre-populate the form.
Patches
Upgrade to 2.12.0 or later.
Workarounds
None
References
https://github.com/mautic/mautic/releases/tag/2.12.0
For more information
If you have any questions or comments about this advisory:
- Email us at security@mautic.org