GHSA-qh8m-9qxx-53m5medium5.4
CakePHP PaginatorHelper::limitControl() vulnerable to reflected cross-site-scripting
Impact
The PaginatorHelper::limitControl() method has a cross-site-scripting vulnerability via query string parameter manipulation.
Source excerpt · OSVAffected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
cakephp/cakephp Packagist
| Affected range | Recorded fix |
|---|---|
| From 5.2.10 before 5.2.12Ecosystem versions | 5.2.12 |
| From 5.3.0 before 5.3.1Ecosystem versions | 5.3.1 |
Version evidence: OSV · GHSA-qh8m-9qxx-53m5
View original version evidence (3 explicit versions)
Original source description
Impact
The PaginatorHelper::limitControl() method has a cross-site-scripting vulnerability via query string parameter manipulation.
Patches
This issue has been fixed in 5.2.12 and 5.3.1
Workarounds
If you are unable to upgrade, you should avoid using Paginator::limitControl() until you can upgrade.
References
- Security advisory github.com/cakephp/cakephp/security/advisories/GHSA-qh8m-9qxx-53m5
- Security advisory nvd.nist.gov/vuln/detail/CVE-2026-23643
- Source reference github.com/cakephp/cakephp/issues/19172
- Patch github.com/cakephp/cakephp/commit/c842e7f45d85696e6527d8991dd72f525ced955f
- Source reference bakery.cakephp.org/2026/01/14/cakephp_5212.html
- Source reference github.com/cakephp/cakephp
- Release notes github.com/cakephp/cakephp/releases/tag/5.2.12
- Release notes github.com/cakephp/cakephp/releases/tag/5.3.1