GHSA-qf79-34j4-54m6medium6.5
Typo3 Improper Access Control
The advisory, in context
TYPO3 before 4.4.9 and 4.5.x before 4.5.4 does not apply proper access control on ExtDirect calls which allows remote attackers to retrieve ExtDirect endpoint services.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
typo3/cms Packagist
Ecosystem versions
Earlier releases before 4.4.9
Fixed in 4.4.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "4.4.9"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}typo3/cms Packagist
Ecosystem versions
From 4.5.0 before 4.5.4
Fixed in 4.5.4
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.5.0"
},
{
"fixed": "4.5.4"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}