Mautic has insufficient authentication in upgrade flow
The advisory, in context
Impact
Mautic allows you to update the application via an upgrade script.
The upgrade logic isn't shielded off correctly, which may lead to vulnerable situation.
This vulnerability is mitigated by the fact that Mautic needs to be installed in a certain way to be vulnerable
Patches
Please upgrade to 4.4.1 or 5.1.1 or later.
Workarounds
None.
For more information
If you have any questions or comments about this advisory:
- Email us at security@mautic.org
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 1.0.0-beta3 before 4.4.13
Fixed in 4.4.13
148 explicitly affected versions
1.0.0, 1.0.0-beta3, 1.0.0-beta4, 1.0.0-rc1, 1.0.0-rc2, 1.0.0-rc3, 1.0.0-rc4, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.0.5, 1.1.0, 1.1.1, 1.1.2, 1.1.3, 1.2.0, 1.2.0-beta1, 1.2.1, 1.2.2, 1.2.3, 1.2.4, 1.3.0, 1.3.1, 1.4.0, 1.4.1, 2.0.0, 2.0.1, 2.1.0, 2.1.1, 2.10.0, 2.10.0-beta, 2.10.1, 2.11.0, 2.11.0-beta, 2.12.0, 2.12.0-beta, 2.12.1, 2.12.1-beta, 2.12.2, 2.12.2-beta, 2.13.0, 2.13.0-beta, 2.13.1, 2.14.0, 2.14.0-beta, 2.14.1, 2.14.1-beta, 2.14.2, 2.14.2-beta, 2.15.0, 2.15.0-beta, 2.15.1, 2.15.1-beta, 2.15.2, 2.15.2-beta, 2.15.3, 2.15.3-beta, 2.16.0, 2.16.0-beta, 2.16.1, 2.16.1-beta, 2.16.2, 2.16.2-beta, 2.16.3, 2.16.3-beta, 2.16.4, 2.16.5, 2.2.0, 2.2.1, 2.3.0, 2.4.0, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.7.0, 2.7.1, 2.8.0, 2.8.1, 2.8.2, 2.9.0, 2.9.0-beta, 2.9.1, 2.9.2, 3.0.0, 3.0.0-alpha, 3.0.0-beta, 3.0.0-beta2, 3.0.1, 3.0.2, 3.0.2-rc, 3.1.0, 3.1.0-rc, 3.1.1, 3.1.1-rc, 3.1.2, 3.1.2-rc, 3.2.0, 3.2.0-rc, 3.2.1, 3.2.2, 3.2.2-rc, 3.2.3, 3.2.4, 3.2.5, 3.2.5-rc, 3.3.0, 3.3.0-rc, 3.3.1, 3.3.2, 3.3.2-rc, 3.3.3, 3.3.3-rc, 3.3.4, 3.3.5, 4.0.0, 4.0.0-alpha1, 4.0.0-beta, 4.0.0-rc, 4.0.1, 4.0.2, 4.1.0, 4.1.1, 4.1.2, 4.2.0, 4.2.0-rc, 4.2.0-rc1, 4.2.1, 4.2.2, 4.3.0, 4.3.0-beta, 4.3.0-rc, 4.3.1, 4.4.0, 4.4.0-beta, 4.4.1, 4.4.10, 4.4.11, 4.4.12, 4.4.2, 4.4.3, 4.4.4, 4.4.5, 4.4.6, 4.4.7, 4.4.8, 4.4.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.0.0-beta3"
},
{
"fixed": "4.4.13"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.0.0",
"1.0.0-beta3",
"1.0.0-beta4",
"1.0.0-rc1",
"1.0.0-rc2",
"1.0.0-rc3",
"1.0.0-rc4",
"1.0.1",
"1.0.2",
"1.0.3",
"1.0.4",
"1.0.5",
"1.1.0",
"1.1.1",
"1.1.2",
"1.1.3",
"1.2.0",
"1.2.0-beta1",
"1.2.1",
"1.2.2",
"1.2.3",
"1.2.4",
"1.3.0",
"1.3.1",
"1.4.0",
"1.4.1",
"2.0.0",
"2.0.1",
"2.1.0",
"2.1.1",
"2.10.0",
"2.10.0-beta",
"2.10.1",
"2.11.0",
"2.11.0-beta",
"2.12.0",
"2.12.0-beta",
"2.12.1",
"2.12.1-beta",
"2.12.2",
"2.12.2-beta",
"2.13.0",
"2.13.0-beta",
"2.13.1",
"2.14.0",
"2.14.0-beta",
"2.14.1",
"2.14.1-beta",
"2.14.2",
"2.14.2-beta",
"2.15.0",
"2.15.0-beta",
"2.15.1",
"2.15.1-beta",
"2.15.2",
"2.15.2-beta",
"2.15.3",
"2.15.3-beta",
"2.16.0",
"2.16.0-beta",
"2.16.1",
"2.16.1-beta",
"2.16.2",
"2.16.2-beta",
"2.16.3",
"2.16.3-beta",
"2.16.4",
"2.16.5",
"2.2.0",
"2.2.1",
"2.3.0",
"2.4.0",
"2.5.0",
"2.5.1",
"2.6.0",
"2.6.1",
"2.7.0",
"2.7.1",
"2.8.0",
"2.8.1",
"2.8.2",
"2.9.0",
"2.9.0-beta",
"2.9.1",
"2.9.2",
"3.0.0",
"3.0.0-alpha",
"3.0.0-beta",
"3.0.0-beta2",
"3.0.1",
"3.0.2",
"3.0.2-rc",
"3.1.0",
"3.1.0-rc",
"3.1.1",
"3.1.1-rc",
"3.1.2",
"3.1.2-rc",
"3.2.0",
"3.2.0-rc",
"3.2.1",
"3.2.2",
"3.2.2-rc",
"3.2.3",
"3.2.4",
"3.2.5",
"3.2.5-rc",
"3.3.0",
"3.3.0-rc",
"3.3.1",
"3.3.2",
"3.3.2-rc",
"3.3.3",
"3.3.3-rc",
"3.3.4",
"3.3.5",
"4.0.0",
"4.0.0-alpha1",
"4.0.0-beta",
"4.0.0-rc",
"4.0.1",
"4.0.2",
"4.1.0",
"4.1.1",
"4.1.2",
"4.2.0",
"4.2.0-rc",
"4.2.0-rc1",
"4.2.1",
"4.2.2",
"4.3.0",
"4.3.0-beta",
"4.3.0-rc",
"4.3.1",
"4.4.0",
"4.4.0-beta",
"4.4.1",
"4.4.10",
"4.4.11",
"4.4.12",
"4.4.2",
"4.4.3",
"4.4.4",
"4.4.5",
"4.4.6",
"4.4.7",
"4.4.8",
"4.4.9"
]
}From 5.0.0-alpha before 5.1.1
Fixed in 5.1.1
12 explicitly affected versions
5.0.0, 5.0.0-alpha, 5.0.0-alpha1, 5.0.0-beta1, 5.0.0-beta2, 5.0.0-rc1, 5.0.0-rc2, 5.0.1, 5.0.2, 5.0.3, 5.0.4, 5.1.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "5.0.0-alpha"
},
{
"fixed": "5.1.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"5.0.0",
"5.0.0-alpha",
"5.0.0-alpha1",
"5.0.0-beta1",
"5.0.0-beta2",
"5.0.0-rc1",
"5.0.0-rc2",
"5.0.1",
"5.0.2",
"5.0.3",
"5.0.4",
"5.1.0"
]
}From 1.0.0-beta3 before 4.4.13
Fixed in 4.4.13
32 explicitly affected versions
4.0.0, 4.0.0-alpha1, 4.0.0-beta, 4.0.0-rc, 4.0.1, 4.0.2, 4.1.0, 4.1.1, 4.1.2, 4.2.0, 4.2.0-rc, 4.2.0-rc1, 4.2.1, 4.2.2, 4.3.0, 4.3.0-beta, 4.3.0-rc, 4.3.1, 4.4.0, 4.4.1, 4.4.1-alpha, 4.4.10, 4.4.11, 4.4.12, 4.4.2, 4.4.3, 4.4.4, 4.4.5, 4.4.6, 4.4.7, 4.4.8, 4.4.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.0.0-beta3"
},
{
"fixed": "4.4.13"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"4.0.0",
"4.0.0-alpha1",
"4.0.0-beta",
"4.0.0-rc",
"4.0.1",
"4.0.2",
"4.1.0",
"4.1.1",
"4.1.2",
"4.2.0",
"4.2.0-rc",
"4.2.0-rc1",
"4.2.1",
"4.2.2",
"4.3.0",
"4.3.0-beta",
"4.3.0-rc",
"4.3.1",
"4.4.0",
"4.4.1",
"4.4.1-alpha",
"4.4.10",
"4.4.11",
"4.4.12",
"4.4.2",
"4.4.3",
"4.4.4",
"4.4.5",
"4.4.6",
"4.4.7",
"4.4.8",
"4.4.9"
]
}From 5.0.0-alpha before 5.1.1
Fixed in 5.1.1
12 explicitly affected versions
5.0.0, 5.0.0-alpha, 5.0.0-alpha1, 5.0.0-beta1, 5.0.0-beta2, 5.0.0-rc1, 5.0.0-rc2, 5.0.1, 5.0.2, 5.0.3, 5.0.4, 5.1.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "5.0.0-alpha"
},
{
"fixed": "5.1.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"5.0.0",
"5.0.0-alpha",
"5.0.0-alpha1",
"5.0.0-beta1",
"5.0.0-beta2",
"5.0.0-rc1",
"5.0.0-rc2",
"5.0.1",
"5.0.2",
"5.0.3",
"5.0.4",
"5.1.0"
]
}References
- https://github.com/mautic/mautic/security/advisories/GHSA-qf6m-6m4g-rmrc
- https://nvd.nist.gov/vuln/detail/CVE-2022-25770
- https://github.com/mautic/mautic/commit/73b18e9a434a28e528fe0e3d03620e7367bdcdca
- https://github.com/mautic/mautic/commit/aee7bfb7510a83acf178a7f02da9661c040e9abf
- https://github.com/mautic/mautic