DB-GPT is vulnerable to SQL Injection attacks from unauthenticated users
The advisory, in context
In eosphoros-ai/db-gpt version v0.6.0, the web API POST /api/v1/editor/sql/run allows execution of arbitrary SQL queries without any access control. This vulnerability can be exploited by attackers to perform Arbitrary File Write using DuckDB SQL, enabling them to write arbitrary files to the victim's file system. This can potentially lead to Remote Code Execution (RCE).
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 0.7.1
Fixed in 0.7.1
32 explicitly affected versions
0.4.7, 0.5.0, 0.5.1, 0.5.10, 0.5.1rc0, 0.5.2, 0.5.2rc0, 0.5.3, 0.5.3rc0, 0.5.4, 0.5.4rc0, 0.5.5, 0.5.5rc0, 0.5.6, 0.5.6rc0, 0.5.7, 0.5.7rc0, 0.5.8, 0.5.9, 0.5.9rc0, 0.6.1, 0.6.2, 0.6.3, 0.6.3rc0, 0.6.3rc1, 0.6.3rc2, 0.6.3rc3, 0.7.0, 0.7.0rc0, 0.7.0rc1, 0.7.1rc0, 0.7.1rc1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "0.7.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"0.4.7",
"0.5.0",
"0.5.1",
"0.5.10",
"0.5.1rc0",
"0.5.2",
"0.5.2rc0",
"0.5.3",
"0.5.3rc0",
"0.5.4",
"0.5.4rc0",
"0.5.5",
"0.5.5rc0",
"0.5.6",
"0.5.6rc0",
"0.5.7",
"0.5.7rc0",
"0.5.8",
"0.5.9",
"0.5.9rc0",
"0.6.1",
"0.6.2",
"0.6.3",
"0.6.3rc0",
"0.6.3rc1",
"0.6.3rc2",
"0.6.3rc3",
"0.7.0",
"0.7.0rc0",
"0.7.0rc1",
"0.7.1rc0",
"0.7.1rc1"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2024-10835
- https://github.com/eosphoros-ai/DB-GPT/pull/2650
- https://github.com/eosphoros-ai/DB-GPT
- https://github.com/eosphoros-ai/DB-GPT/releases/tag/v0.7.1
- https://github.com/pypa/advisory-database/tree/main/vulns/dbgpt/PYSEC-2026-325.yaml
- https://huntr.com/bounties/e32fda74-ca83-431c-8de8-08274ba686c9
- https://pypi.org/project/dbgpt