Magento Unauthorized access to restricted resources
The advisory, in context
Magento versions 2.4.2 (and earlier), 2.4.1-p1 (and earlier) and 2.3.6-p1 (and earlier) are affected by an Improper Authorization vulnerability via the 'Create Customer' endpoint. Successful exploitation could lead to unauthorized modification of customer data by an unauthenticated attacker. Access to the admin console is required for successful exploitation.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 2.4.0 before 2.4.2-p1
Fixed in 2.4.2-p1
5 explicitly affected versions
2.4.0, 2.4.0-p1, 2.4.1, 2.4.1-p1, 2.4.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.4.0"
},
{
"fixed": "2.4.2-p1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.4.0",
"2.4.0-p1",
"2.4.1",
"2.4.1-p1",
"2.4.2"
]
}Earlier releases before 2.3.7
Fixed in 2.3.7
121 explicitly affected versions
0.1.0-alpha100, 0.1.0-alpha101, 0.1.0-alpha102, 0.1.0-alpha103, 0.1.0-alpha104, 0.1.0-alpha105, 0.1.0-alpha106, 0.1.0-alpha107, 0.1.0-alpha108, 0.1.0-alpha89, 0.1.0-alpha90, 0.1.0-alpha91, 0.1.0-alpha92, 0.1.0-alpha93, 0.1.0-alpha94, 0.1.0-alpha95, 0.1.0-alpha96, 0.1.0-alpha97, 0.1.0-alpha98, 0.1.0-alpha99, 0.42.0-beta1, 0.42.0-beta10, 0.42.0-beta11, 0.42.0-beta2, 0.42.0-beta3, 0.42.0-beta4, 0.42.0-beta5, 0.42.0-beta6, 0.42.0-beta7, 0.42.0-beta8, 0.42.0-beta9, 0.74.0-beta1, 0.74.0-beta10, 0.74.0-beta11, 0.74.0-beta12, 0.74.0-beta13, 0.74.0-beta14, 0.74.0-beta15, 0.74.0-beta16, 0.74.0-beta2, 0.74.0-beta3, 0.74.0-beta4, 0.74.0-beta5, 0.74.0-beta6, 0.74.0-beta7, 0.74.0-beta8, 0.74.0-beta9, 1.0.0-beta, 1.0.0-beta2, 1.0.0-beta3, 1.0.0-beta4, 1.0.0-beta5, 1.0.0-beta6, 2.0.0, 2.0.0-rc, 2.0.0-rc2, 2.0.1, 2.0.10, 2.0.11, 2.0.12, 2.0.13, 2.0.14, 2.0.15, 2.0.16, 2.0.17, 2.0.18, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6, 2.0.7, 2.0.8, 2.0.9, 2.1.0, 2.1.0-rc1, 2.1.0-rc2, 2.1.0-rc3, 2.1.1, 2.1.10, 2.1.11, 2.1.12, 2.1.13, 2.1.14, 2.1.15, 2.1.16, 2.1.17, 2.1.18, 2.1.2, 2.1.3, 2.1.4, 2.1.5, 2.1.6, 2.1.7, 2.1.8, 2.1.9, 2.2.0, 2.2.1, 2.2.10, 2.2.11, 2.2.2, 2.2.3, 2.2.4, 2.2.5, 2.2.6, 2.2.7, 2.2.8, 2.2.9, 2.3.0, 2.3.1, 2.3.2, 2.3.2-p2, 2.3.3, 2.3.3-p1, 2.3.4, 2.3.4-p2, 2.3.5, 2.3.5-p1, 2.3.5-p2, 2.3.6, 2.3.6-p1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "2.3.7"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"0.1.0-alpha100",
"0.1.0-alpha101",
"0.1.0-alpha102",
"0.1.0-alpha103",
"0.1.0-alpha104",
"0.1.0-alpha105",
"0.1.0-alpha106",
"0.1.0-alpha107",
"0.1.0-alpha108",
"0.1.0-alpha89",
"0.1.0-alpha90",
"0.1.0-alpha91",
"0.1.0-alpha92",
"0.1.0-alpha93",
"0.1.0-alpha94",
"0.1.0-alpha95",
"0.1.0-alpha96",
"0.1.0-alpha97",
"0.1.0-alpha98",
"0.1.0-alpha99",
"0.42.0-beta1",
"0.42.0-beta10",
"0.42.0-beta11",
"0.42.0-beta2",
"0.42.0-beta3",
"0.42.0-beta4",
"0.42.0-beta5",
"0.42.0-beta6",
"0.42.0-beta7",
"0.42.0-beta8",
"0.42.0-beta9",
"0.74.0-beta1",
"0.74.0-beta10",
"0.74.0-beta11",
"0.74.0-beta12",
"0.74.0-beta13",
"0.74.0-beta14",
"0.74.0-beta15",
"0.74.0-beta16",
"0.74.0-beta2",
"0.74.0-beta3",
"0.74.0-beta4",
"0.74.0-beta5",
"0.74.0-beta6",
"0.74.0-beta7",
"0.74.0-beta8",
"0.74.0-beta9",
"1.0.0-beta",
"1.0.0-beta2",
"1.0.0-beta3",
"1.0.0-beta4",
"1.0.0-beta5",
"1.0.0-beta6",
"2.0.0",
"2.0.0-rc",
"2.0.0-rc2",
"2.0.1",
"2.0.10",
"2.0.11",
"2.0.12",
"2.0.13",
"2.0.14",
"2.0.15",
"2.0.16",
"2.0.17",
"2.0.18",
"2.0.2",
"2.0.3",
"2.0.4",
"2.0.5",
"2.0.6",
"2.0.7",
"2.0.8",
"2.0.9",
"2.1.0",
"2.1.0-rc1",
"2.1.0-rc2",
"2.1.0-rc3",
"2.1.1",
"2.1.10",
"2.1.11",
"2.1.12",
"2.1.13",
"2.1.14",
"2.1.15",
"2.1.16",
"2.1.17",
"2.1.18",
"2.1.2",
"2.1.3",
"2.1.4",
"2.1.5",
"2.1.6",
"2.1.7",
"2.1.8",
"2.1.9",
"2.2.0",
"2.2.1",
"2.2.10",
"2.2.11",
"2.2.2",
"2.2.3",
"2.2.4",
"2.2.5",
"2.2.6",
"2.2.7",
"2.2.8",
"2.2.9",
"2.3.0",
"2.3.1",
"2.3.2",
"2.3.2-p2",
"2.3.3",
"2.3.3-p1",
"2.3.4",
"2.3.4-p2",
"2.3.5",
"2.3.5-p1",
"2.3.5-p2",
"2.3.6",
"2.3.6-p1"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2021-28563
- https://github.com/magento/magento2/commit/1bd5cb8c065e44779526c0b044ce19b884707695
- https://github.com/magento/magento2/commit/ed952726c94e401e922e88490e41a536f2d850e7
- https://github.com/magento/magento2
- https://helpx.adobe.com/security/products/magento/apsb21-30.html