GHSA-q9p4-qfc8-fvppcritical9.8
SQL Injection in medoo
The advisory, in context
columnQuote in medoo before 1.7.5 allows remote attackers to perform a SQL Injection due to improper escaping.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
catfan/medoo Packagist
Ecosystem versions
Earlier releases before 1.7.5
Fixed in 1.7.5
34 explicitly affected versions
v0.9.5.3, v0.9.6, v0.9.6.2, v0.9.7, v0.9.8, v1.0, v1.0.2, v1.1, v1.1.1, v1.1.2, v1.2, v1.2.1, v1.4, v1.4.1, v1.4.2, v1.4.3, v1.4.4, v1.4.5, v1.5, v1.5.1, v1.5.2, v1.5.3, v1.5.4, v1.5.5, v1.5.6, v1.5.7, v1.5a, v1.6, v1.6.1, v1.7.0, v1.7.1, v1.7.2, v1.7.3, v1.7.4
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.7.5"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v0.9.5.3",
"v0.9.6",
"v0.9.6.2",
"v0.9.7",
"v0.9.8",
"v1.0",
"v1.0.2",
"v1.1",
"v1.1.1",
"v1.1.2",
"v1.2",
"v1.2.1",
"v1.4",
"v1.4.1",
"v1.4.2",
"v1.4.3",
"v1.4.4",
"v1.4.5",
"v1.5",
"v1.5.1",
"v1.5.2",
"v1.5.3",
"v1.5.4",
"v1.5.5",
"v1.5.6",
"v1.5.7",
"v1.5a",
"v1.6",
"v1.6.1",
"v1.7.0",
"v1.7.1",
"v1.7.2",
"v1.7.3",
"v1.7.4"
]
}