GHSA-q99w-j4mj-7hj8medium6.5
Contao Information Disclosure via Access Control Flaws
The advisory, in context
Contao 3.x before 3.5.37, 4.4.x before 4.4.31 and 4.6.x before 4.6.11 has Incorrect Access Control.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
contao/contao Packagist
Ecosystem versions
From 3.0.0 before 3.5.37
Fixed in 3.5.37
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.0.0"
},
{
"fixed": "3.5.37"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}contao/contao Packagist
Ecosystem versions
From 4.6.0 before 4.6.11
Fixed in 4.6.11
11 explicitly affected versions
4.6.0, 4.6.1, 4.6.10, 4.6.2, 4.6.3, 4.6.4, 4.6.5, 4.6.6, 4.6.7, 4.6.8, 4.6.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.6.0"
},
{
"fixed": "4.6.11"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"4.6.0",
"4.6.1",
"4.6.10",
"4.6.2",
"4.6.3",
"4.6.4",
"4.6.5",
"4.6.6",
"4.6.7",
"4.6.8",
"4.6.9"
]
}contao/contao Packagist
Ecosystem versions
From 4.4.0 before 4.4.31
Fixed in 4.4.31
9 explicitly affected versions
4.4.22, 4.4.23, 4.4.24, 4.4.25, 4.4.26, 4.4.27, 4.4.28, 4.4.29, 4.4.30
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.4.0"
},
{
"fixed": "4.4.31"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"4.4.22",
"4.4.23",
"4.4.24",
"4.4.25",
"4.4.26",
"4.4.27",
"4.4.28",
"4.4.29",
"4.4.30"
]
}