GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GHSA-q7g6-xfh2-vhpxmedium5.5

phpMyFAQ stored Cross-site Scripting at user email

Check your stack

The advisory, in context

Summary

The email field in phpMyFAQ's user control panel page is vulnerable to stored XSS attacks due to the inadequacy of PHP's FILTER_VALIDATE_EMAIL function, which only validates the email format, not its content. This vulnerability enables an attacker to execute arbitrary client-side JavaScript within the context of another user's phpMyFAQ session.

Details

Despite using PHP's FILTER_VALIDATE_EMAIL function, the email field does not adequately validate the content of the email address. This means that malicious input, such as JavaScript code, can be accepted and stored in the database without being detected. When the stored data is retrieved and displayed on web pages, it is not properly sanitized to remove or neutralize any potentially harmful content, such as JavaScript code which leads to Stored XSS.

PoC

  1. Login as any user, go to the user control panel, change email to any valid email and intercept the request.

  2. Modify the request’s email parameter to the following payload: "><svg/onload=confirm('XSS')>"@x.y image

  3. Send the request and see that the XSS is triggered in the user control panel page. image

  4. Also affects any user who browse to "../admin/?action=user&user_action=listallusers" image

Impact

This allows an attacker to execute arbitrary client side JavaScript within the context of another user's phpMyFAQ session.

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Ecosystem versions

From 3.2.5 before 3.2.6

Fixed in 3.2.6

1 explicitly affected versions

3.2.5

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "3.2.5"
        },
        {
          "fixed": "3.2.6"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "3.2.5"
  ]
}

References