eZ Platform Admin UI Cross-site Scripting vulnerability
The advisory, in context
This security advisory fixes a severe vulnerability in the eZ Platform Admin UI, and we recommend that you install it as soon as possible. Parts of the Admin UI are vulnerable to XSS injection. All 2.x sites are at risk, and particularly those that allow user generated content. The update adds the necessary escaping of injected code. This resolves the issue both for code that has already been injected, and any future such code.
To install, use Composer to update "ezsystems/ezplatform-admin-ui" and "ezsystems/ezplatform-page-builder" to one of the "Resolving versions" mentioned above. (ezplatform-page-builder exists only in eZ Platform Enterprise Edition.)
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 1.3.0 before 1.3.5
Fixed in 1.3.5
6 explicitly affected versions
v1.3.0, v1.3.1, v1.3.2, v1.3.3, v1.3.4, v1.3.5-rc1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.3.0"
},
{
"fixed": "1.3.5"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v1.3.0",
"v1.3.1",
"v1.3.2",
"v1.3.3",
"v1.3.4",
"v1.3.5-rc1"
]
}From 1.4.0 before 1.4.4
Fixed in 1.4.4
5 explicitly affected versions
v1.4.0, v1.4.1, v1.4.2, v1.4.3, v1.4.3-rc1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.4.0"
},
{
"fixed": "1.4.4"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v1.4.0",
"v1.4.1",
"v1.4.2",
"v1.4.3",
"v1.4.3-rc1"
]
}References
- https://github.com/FriendsOfPHP/security-advisories/blob/master/ezsystems/ezplatform-admin-ui/CVE-2019-12139.yaml
- https://github.com/ezsystems/ezplatform-admin-ui
- https://share.ez.no/community-project/security-advisories/ezsa-2019-001-xss-in-admin-ui
- https://web.archive.org/web/20201207160038/https://share.ez.no/community-project/security-advisories/ezsa-2019-001-xss-in-admin-ui