Concrete CMS Stored Cross-site Scripting vulnerability
The advisory, in context
Concrete CMS versions 9.0.0 to 9.3.2 and below 8.5.18 are vulnerable to Stored XSS in RSS Displayer when user input is stored and later embedded into responses. A rogue administrator could inject malicious code into fields due to insufficient input validation.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 8.5.18
Fixed in 8.5.18
40 explicitly affected versions
8.0, 8.0.1, 8.0.2, 8.0.3, 8.1.0, 8.2.0, 8.2.0RC2, 8.2.1, 8.3.0, 8.3.1, 8.3.2, 8.4.0, 8.4.0RC3, 8.4.0RC4, 8.4.1, 8.4.2, 8.4.3, 8.4.4, 8.4.5, 8.5.0, 8.5.0RC1, 8.5.0RC2, 8.5.1, 8.5.10, 8.5.11, 8.5.12, 8.5.13, 8.5.14, 8.5.15, 8.5.16, 8.5.17, 8.5.2, 8.5.3, 8.5.4, 8.5.5, 8.5.6, 8.5.6RC1, 8.5.7, 8.5.8, 8.5.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "8.5.18"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"8.0",
"8.0.1",
"8.0.2",
"8.0.3",
"8.1.0",
"8.2.0",
"8.2.0RC2",
"8.2.1",
"8.3.0",
"8.3.1",
"8.3.2",
"8.4.0",
"8.4.0RC3",
"8.4.0RC4",
"8.4.1",
"8.4.2",
"8.4.3",
"8.4.4",
"8.4.5",
"8.5.0",
"8.5.0RC1",
"8.5.0RC2",
"8.5.1",
"8.5.10",
"8.5.11",
"8.5.12",
"8.5.13",
"8.5.14",
"8.5.15",
"8.5.16",
"8.5.17",
"8.5.2",
"8.5.3",
"8.5.4",
"8.5.5",
"8.5.6",
"8.5.6RC1",
"8.5.7",
"8.5.8",
"8.5.9"
]
}From 9.0.0RC1 before 9.3.3
Fixed in 9.3.3
24 explicitly affected versions
9.0.0, 9.0.0RC1, 9.0.0RC3, 9.0.0RC4, 9.0.1, 9.0.2, 9.1.0, 9.1.1, 9.1.2, 9.1.3, 9.2.0, 9.2.0RC2, 9.2.1, 9.2.2, 9.2.3, 9.2.4, 9.2.5, 9.2.6, 9.2.7, 9.2.8, 9.2.9, 9.3.0, 9.3.1, 9.3.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "9.0.0RC1"
},
{
"fixed": "9.3.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"9.0.0",
"9.0.0RC1",
"9.0.0RC3",
"9.0.0RC4",
"9.0.1",
"9.0.2",
"9.1.0",
"9.1.1",
"9.1.2",
"9.1.3",
"9.2.0",
"9.2.0RC2",
"9.2.1",
"9.2.2",
"9.2.3",
"9.2.4",
"9.2.5",
"9.2.6",
"9.2.7",
"9.2.8",
"9.2.9",
"9.3.0",
"9.3.1",
"9.3.2"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2024-4350
- https://github.com/concretecms/concretecms/pull/12166
- https://github.com/concretecms/concretecms/commit/55e485e06b0b3342613a55af6a7c61d939d2ccb5
- https://github.com/concretecms/concretecms/commit/c08d9671cec4e7afdabb547339c4bc0bed8eab06
- https://documentation.concretecms.org/9-x/developers/introduction/version-history/933-release-notes?pk_vid=e367a434ef4830491723060415d52041
- https://documentation.concretecms.org/developers/introduction/version-history/8518-release-notes?pk_vid=e367a434ef4830491723055758d52041
- https://github.com/concretecms/concretecms