GHSA-q586-xpwr-jc3jlow
phpMyAdmin cross-site scripting vulnerability in crafted view name
The advisory, in context
A cross-site scripting (XSS) vulnerability in the view operations page in phpMyAdmin 4.1.x before 4.1.14.3 and 4.2.x before 4.2.7.1 allows remote authenticated users to inject arbitrary web script or HTML via a crafted view name, related to js/functions.js.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
phpmyadmin/phpmyadmin Packagist
Ecosystem versions
From 4.1.0 before 4.1.14.3
Fixed in 4.1.14.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.1.0"
},
{
"fixed": "4.1.14.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}phpmyadmin/phpmyadmin Packagist
Ecosystem versions
From 4.2.0 before 4.2.7.1
Fixed in 4.2.7.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.2.0"
},
{
"fixed": "4.2.7.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}