GHSA-q3r2-23r8-wqr9medium6.1
frp_form_answers allows Cross-site Scripting
The advisory, in context
The frp_form_answers (aka Forms Export) extension before 3.1.2, and 4.x before 4.0.2, for TYPO3 allows XSS via saved emails.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
frappant/frp-form-answers Packagist
Ecosystem versions
Earlier releases before 3.1.2
Fixed in 3.1.2
10 explicitly affected versions
1.0.1, 1.1.0, 1.3.0, 2.0.0, 2.0.1, 2.0.2, 3.0.0, 3.0.1, 3.1.0, 3.1.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "3.1.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.0.1",
"1.1.0",
"1.3.0",
"2.0.0",
"2.0.1",
"2.0.2",
"3.0.0",
"3.0.1",
"3.1.0",
"3.1.1"
]
}frappant/frp-form-answers Packagist
Ecosystem versions
From 4.0.0 before 4.0.2
Fixed in 4.0.2
2 explicitly affected versions
4.0.0, 4.0.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.0.0"
},
{
"fixed": "4.0.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"4.0.0",
"4.0.1"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2023-26091
- https://github.com/frappant/frp_form_answers/commit/39fa16c8c792abdfc33e38bae17847364ff6a71d
- https://github.com/FriendsOfPHP/security-advisories/blob/master/frappant/frp-form-answers/CVE-2023-26091.yaml
- https://github.com/frappant/frp_form_answers
- https://typo3.org/help/security-advisories
- https://typo3.org/security/advisory/typo3-ext-sa-2023-002