GHSA-q348-f93x-9gx4critical
Lack of Input Validation in zendesk_api_client_php for Zendesk Subdomain
The advisory, in context
Impact
Lack of input validation of the Zendesk subdomain could expose users of the library to Server Side Request Forgery (SSRF).
Resolution
Validate the provided Zendesk subdomain to be a valid subdomain in:
- getAuthUrl
- getAccessToken
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
zendesk/zendesk_api_client_php Packagist
Ecosystem versions
Earlier releases before 2.2.11
Fixed in 2.2.11
37 explicitly affected versions
2.0.0-beta, 2.0.9, v1.0.0, v1.1.0, v1.1.1, v1.1.2, v1.2.0, v1.2.1, v2.0.3, v2.0.4, v2.0.5, v2.0.6, v2.0.7, v2.0.8, v2.1.0, v2.1.1, v2.1.10, v2.1.11, v2.1.2, v2.1.3, v2.1.4, v2.1.5, v2.1.6, v2.1.7, v2.1.8, v2.1.9, v2.2.0, v2.2.1, v2.2.10, v2.2.2, v2.2.3, v2.2.4, v2.2.5, v2.2.6, v2.2.7, v2.2.8, v2.2.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "2.2.11"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.0.0-beta",
"2.0.9",
"v1.0.0",
"v1.1.0",
"v1.1.1",
"v1.1.2",
"v1.2.0",
"v1.2.1",
"v2.0.3",
"v2.0.4",
"v2.0.5",
"v2.0.6",
"v2.0.7",
"v2.0.8",
"v2.1.0",
"v2.1.1",
"v2.1.10",
"v2.1.11",
"v2.1.2",
"v2.1.3",
"v2.1.4",
"v2.1.5",
"v2.1.6",
"v2.1.7",
"v2.1.8",
"v2.1.9",
"v2.2.0",
"v2.2.1",
"v2.2.10",
"v2.2.2",
"v2.2.3",
"v2.2.4",
"v2.2.5",
"v2.2.6",
"v2.2.7",
"v2.2.8",
"v2.2.9"
]
}