GHSA-pwgg-r6fq-mf94medium5.4
YOURLS Stored Cross Site Scripting (XSS)
The advisory, in context
Multiple Stored Cross Site Scripting (XSS) vulnerabilities exist in the YOURLS Admin Panel, Versions 1.5 - 1.7.10. An authenticated user must modify a PHP plugin with a malicious payload and upload it, resulting in multiple stored XSS issues.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
yourls/yourls Packagist
Ecosystem versions
From 1.5 before 1.8
Fixed in 1.8
7 explicitly affected versions
1.7.1, 1.7.2, 1.7.3, 1.7.4, 1.7.5, 1.7.6, 1.7.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.5"
},
{
"fixed": "1.8"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.7.1",
"1.7.2",
"1.7.3",
"1.7.4",
"1.7.5",
"1.7.6",
"1.7.9"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2020-27388
- https://github.com/YOURLS/YOURLS/pull/2761
- https://github.com/YOURLS/YOURLS/pull/2761/commits/93396c14587ece4f3d7bcb654f6d22eb0bae7d74
- https://github.com/YOURLS/YOURLS/commit/04495e8b17ffeedb695ef5a64389f6bee15d57fb
- https://github.com/YOURLS/YOURLS
- https://johnjhacking.com/blog/cve-2020-27388
- http://yourls.org