GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GHSA-pw9p-jvrm-f7rmhigh7.5

PHP Standard Library: HTTP/2 server-side missing content-length validation enables request smuggling

Check your stack

The advisory, in context

Impact

Psl\H2\ServerConnection does not validate that the total bytes received in DATA frames match the content-length header declared in the HEADERS frame, in violation of RFC 9113 §8.1.1.

A malicious client can:

  • Send more DATA bytes than declared, smuggling additional content past application-level size limits.
  • Send fewer DATA bytes than declared and close the stream early, causing applications that trust the declared length to behave incorrectly.

The vulnerability is only reachable for consumers using Psl\H2\ServerConnection directly to accept untrusted client traffic. The high-level Psl\HTTP\Server is in active development and was not yet released at the time of this advisory; consumers of documented high-level PSL APIs are not affected.

Patches

Fixed in 6.1.2 and 6.2.1.

  • Parses and validates the content-length header on incoming HEADERS (server-side only — clients do not enforce this per RFC 9110 §9.3.2).
  • Tracks cumulative DATA frame payload length per stream.
  • Throws StreamException on mismatch or overflow.

Regression tests landed in #781, 9 of the new tests fail against the pre-fix code, proving the validation boundary is enforced.

Workarounds

None at the protocol layer. Applications using Psl\H2\ServerConnection directly should upgrade.

Resources

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Ecosystem versions

From 6.1.0 before 6.1.2

Fixed in 6.1.2

2 explicitly affected versions

6.1.0, 6.1.1

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "6.1.0"
        },
        {
          "fixed": "6.1.2"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "6.1.0",
    "6.1.1"
  ]
}
Ecosystem versions

From 6.2.0 before 6.2.1

Fixed in 6.2.1

1 explicitly affected versions

6.2.0

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "6.2.0"
        },
        {
          "fixed": "6.2.1"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "6.2.0"
  ]
}
Ecosystem versions

From 6.1.0 before 6.1.2

Fixed in 6.1.2

2 explicitly affected versions

6.1.0, 6.1.1

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "6.1.0"
        },
        {
          "fixed": "6.1.2"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "6.1.0",
    "6.1.1"
  ]
}
Ecosystem versions

From 6.2.0 before 6.2.1

Fixed in 6.2.1

1 explicitly affected versions

6.2.0

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "6.2.0"
        },
        {
          "fixed": "6.2.1"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "6.2.0"
  ]
}

References