EC-CUBE improperly handles HTTP Host header values
The advisory, in context
EC-CUBE 3.0.0 to 3.0.18-p3 and EC-CUBE 4.0.0 to 4.1.1 improperly handle HTTP Host header values, which may lead a remote unauthenticated attacker to direct the vulnerable version of EC-CUBE to send an Email with some forged reissue-password URL to EC-CUBE users.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 3.0.0 through 3.0.18-p3 (inclusive)
No fix recorded for this interval.
21 explicitly affected versions
3.0.0, 3.0.1, 3.0.10, 3.0.11, 3.0.11-RC, 3.0.12, 3.0.12-p1, 3.0.13, 3.0.14, 3.0.15, 3.0.16, 3.0.17, 3.0.18, 3.0.2, 3.0.3, 3.0.4, 3.0.5, 3.0.6, 3.0.7, 3.0.8, 3.0.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.0.0"
},
{
"last_affected": "3.0.18-p3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"3.0.0",
"3.0.1",
"3.0.10",
"3.0.11",
"3.0.11-RC",
"3.0.12",
"3.0.12-p1",
"3.0.13",
"3.0.14",
"3.0.15",
"3.0.16",
"3.0.17",
"3.0.18",
"3.0.2",
"3.0.3",
"3.0.4",
"3.0.5",
"3.0.6",
"3.0.7",
"3.0.8",
"3.0.9"
]
}From 4.0.0 before 4.1.2
Fixed in 4.1.2
23 explicitly affected versions
4.0.0, 4.0.1, 4.0.2, 4.0.3, 4.0.4, 4.0.5, 4.0.5-p1, 4.0.5-rc, 4.0.6, 4.0.6-p1, 4.0.6-p2, 4.0.6-p3, 4.0.6-p4, 4.0.6-p5, 4.1-beta, 4.1-beta2, 4.1-beta3, 4.1-beta3-20210831, 4.1-beta3-20210901, 4.1-beta3-20210903, 4.1-rc, 4.1.0, 4.1.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.0.0"
},
{
"fixed": "4.1.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"4.0.0",
"4.0.1",
"4.0.2",
"4.0.3",
"4.0.4",
"4.0.5",
"4.0.5-p1",
"4.0.5-rc",
"4.0.6",
"4.0.6-p1",
"4.0.6-p2",
"4.0.6-p3",
"4.0.6-p4",
"4.0.6-p5",
"4.1-beta",
"4.1-beta2",
"4.1-beta3",
"4.1-beta3-20210831",
"4.1-beta3-20210901",
"4.1-beta3-20210903",
"4.1-rc",
"4.1.0",
"4.1.1"
]
}