GHSA-pjv5-v9gv-3679medium5.4
Gravity Forms stored Cross-Site Scripting (XSS) vulnerability in the survey feature
The advisory, in context
A stored Cross-Site Scripting (XSS) vulnerability in the survey feature in Rocketgenius Gravity Forms before 2.4.21 allows remote attackers to inject arbitrary web script or HTML via a textarea field. This code is interpreted by users in a privileged role (Administrator, Editor, etc.).
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
wp-premium/gravityforms Packagist
Ecosystem versions
From 2.4 before 2.4.21
Fixed in 2.4.21
10 explicitly affected versions
2.4.10, 2.4.11, 2.4.12, 2.4.16, 2.4.17, 2.4.20, 2.4.5, 2.4.7.3, 2.4.8, 2.4.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.4"
},
{
"fixed": "2.4.21"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.4.10",
"2.4.11",
"2.4.12",
"2.4.16",
"2.4.17",
"2.4.20",
"2.4.5",
"2.4.7.3",
"2.4.8",
"2.4.9"
]
}