GHSA-phhm-6pgm-mxw9high8.8
MODX Revolution blind SQL injection
The advisory, in context
MODX Revolution version 2.x - 2.5.6 is vulnerable to blind SQL injection caused by improper sanitization by the escape method resulting in authenticated user accessing database and possibly escalating privileges.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
modx/revolution Packagist
Ecosystem versions
From 2.0.0 before 2.6.0
Fixed in 2.6.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.0.0"
},
{
"fixed": "2.6.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}