GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GHSA-ph6g-p72v-pc3pcritical9.8

Orchid Deserialization of Untrusted Data vulnerability leads to Remote Code Execution

Check your stack

The advisory, in context

Orchid is a Laravel package that allows application development of back-office applications, admin/user panels, and dashboards.

Impact

A vulnerability present starting in version 14.0.0-alpha4 and prior to version 14.5.0 is related to the deserialization of untrusted data from the _state query parameter, which can result in remote code execution. This vulnerability is related to the deserialization of untrusted data from the _state query parameter, which can result in remote code execution.

Patches

The issue has been addressed in version 14.5.0. Users are advised to upgrade their software to this version or any subsequent versions that include the patch. There are no known workarounds.

Workarounds

In this case, it is recommended for users to upgrade to the patched version rather than relying on workarounds. Upgrading to the fixed version ensures that the vulnerability is no longer present and provides the best protection against remote code execution

References

For more detailed information about this workaround and its effectiveness, users should consult the support channels provided by the software or system developer. They can provide specific guidance on implementing this workaround and any potential limitations or caveats associated with it.


This vulnerability was discovered by Vladislav Gladkiy (Positive Technologies)

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Ecosystem versions

From 14.0.0-alpha4 before 14.5.0

Fixed in 14.5.0

14 explicitly affected versions

14.0.0, 14.0.0-alpha4, 14.0.0-alpha5, 14.0.0-alpha6, 14.0.0-alpha7, 14.0.1, 14.0.2, 14.0.3, 14.1.0, 14.1.1, 14.2.0, 14.2.1, 14.3.0, 14.4.0

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "14.0.0-alpha4"
        },
        {
          "fixed": "14.5.0"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "14.0.0",
    "14.0.0-alpha4",
    "14.0.0-alpha5",
    "14.0.0-alpha6",
    "14.0.0-alpha7",
    "14.0.1",
    "14.0.2",
    "14.0.3",
    "14.1.0",
    "14.1.1",
    "14.2.0",
    "14.2.1",
    "14.3.0",
    "14.4.0"
  ]
}

References