GHSA-pgcp-m69h-p2grmedium6.1
Cross-site Scripting (XSS) in moodle
Impact
In Moodle, it was possible to include JavaScript when re-naming content bank items. Versions affected: 3.9 to 3.9.2. This is fixed in moodle 3.9.3 and 3.10.
Source excerpt · OSVAffected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
moodle/moodle Packagist
| Affected range | Recorded fix |
|---|---|
| From 3.9.0 before 3.9.3Ecosystem versions | 3.9.3 |
Version evidence: OSV · GHSA-pgcp-m69h-p2gr
View original version evidence (3 explicit versions)
Original source description
In Moodle, it was possible to include JavaScript when re-naming content bank items. Versions affected: 3.9 to 3.9.2. This is fixed in moodle 3.9.3 and 3.10.
References
- Security advisory nvd.nist.gov/vuln/detail/CVE-2020-25702
- Patch github.com/moodle/moodle/commit/66be08216e647532b295a9132070d2435ecd7ad9
- Source reference bugzilla.redhat.com/show_bug.cgi
- Source reference lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/4NNFCHPPHRJNJROIX6SYMHOC6HMKP3GU
- Source reference lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/B55KXBVAT45MDASJ3EK6VIGQOYGJ4NH6
- Source reference moodle.org/mod/forum/discuss.php