GHSA-p9fg-j6ww-953mmedium
FOSRestBundle issue with broken validation of JSONP callbacks
No CVE assignedCheck your stack
The advisory, in context
Starting with FOSRestBundle 1.2 we switched to using willdurand/jsonp-callback-validator for validation of JSONP callbacks. However the change was implemented incorrectly validating the callback query param name, rather than its value. Anyone using the JSONP handler (which is off by default) together with FOSRestBundle 1.2.0 or 1.2.1 should update to FOSRestBundle 1.2.2.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
friendsofsymfony/rest-bundle Packagist
Ecosystem versions
From 1.2.0 before 1.2.2
Fixed in 1.2.2
2 explicitly affected versions
1.2.0, 1.2.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.2.0"
},
{
"fixed": "1.2.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.2.0",
"1.2.1"
]
}References
- https://github.com/FriendsOfSymfony/FOSRestBundle/commit/3dd7d40068360c23366fb4884c5d194c769ec2c1
- https://github.com/FriendsOfPHP/security-advisories/blob/master/friendsofsymfony/rest-bundle/2014-01-22-1.yaml
- https://github.com/FriendsOfSymfony/FOSRestBundle
- https://symfony.com/blog/fosrestbundle-security-issue-with-jsonp-handler