Configuration Injection in extension "Direct Mail" (direct_mail)
The advisory, in context
The “Configuration” backend module of the extension allows an authenticated user to write arbitrary page TSConfig for folders configured as “Direct Mail”. Exploiting the vulnerability may lead to Configuration Injection (TYPO3 10.4 and above) and to Arbitrary Code Execution (TYPO3 9.5 and below).
A valid backend user account having access to the Direct Mail "Configuration" backend module is needed in order to exploit this vulnerability.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 8.0.0 before 9.5.2
Fixed in 9.5.2
13 explicitly affected versions
9.0.0, 9.0.1, 9.0.2, 9.1.1, 9.1.2, 9.1.3, 9.2.0, 9.2.1, 9.2.2, 9.3.0, 9.4.0, 9.5.0, 9.5.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "8.0.0"
},
{
"fixed": "9.5.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"9.0.0",
"9.0.1",
"9.0.2",
"9.1.1",
"9.1.2",
"9.1.3",
"9.2.0",
"9.2.1",
"9.2.2",
"9.3.0",
"9.4.0",
"9.5.0",
"9.5.1"
]
}From 7.0.0 before 7.0.3
Fixed in 7.0.3
3 explicitly affected versions
7.0.0, v7.0.1, v7.0.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "7.0.0"
},
{
"fixed": "7.0.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"7.0.0",
"v7.0.1",
"v7.0.2"
]
}Earlier releases before 6.0.3
Fixed in 6.0.3
12 explicitly affected versions
5.0, 5.0.1, 5.1.0, 5.2.0, 5.2.1, 5.2.2, 5.2.3, 5.2.4, 6.0.0, 6.0.1, 6.0.2, v5.1.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "6.0.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"5.0",
"5.0.1",
"5.1.0",
"5.2.0",
"5.2.1",
"5.2.2",
"5.2.3",
"5.2.4",
"6.0.0",
"6.0.1",
"6.0.2",
"v5.1.1"
]
}