GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GHSA-p6h7-29r2-g88fhigh

phpMyAdmin vulnerable to static code injection

Check your stack

The advisory, in context

setup/lib/ConfigGenerator.class.php in phpMyAdmin 3.x before 3.3.10.2 and 3.4.x before 3.4.3.1 does not properly restrict the presence of comment closing delimiters, which allows remote attackers to conduct static code injection attacks by leveraging the ability to modify the SESSION superglobal array.

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Ecosystem versions

From 3.0 before 3.3.10.2

Fixed in 3.3.10.2

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "3.0"
        },
        {
          "fixed": "3.3.10.2"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": []
}
Ecosystem versions

From 3.4 before 3.4.3.1

Fixed in 3.4.3.1

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "3.4"
        },
        {
          "fixed": "3.4.3.1"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": []
}

References