GHSA-p523-jrph-qjc6low3.5
Insufficient Session Expiration in shopware
The advisory, in context
Impact
Automatically invalidate sessions upon password change
Patches
We recommend updating to the current version 5.7.7. You can get the update to 5.7.7 regularly via the Auto-Updater or directly via the download overview.
For older versions you can use the Security Plugin: https://store.shopware.com/en/swag575294366635f/shopware-security-plugin.html
References
https://docs.shopware.com/en/shopware-5-en/securityupdates/security-update-01-2022
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
shopware/shopware Packagist
Ecosystem versions
From 5.7.3 before 5.7.7
Fixed in 5.7.7
4 explicitly affected versions
v5.7.3, v5.7.4, v5.7.5, v5.7.6
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "5.7.3"
},
{
"fixed": "5.7.7"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v5.7.3",
"v5.7.4",
"v5.7.5",
"v5.7.6"
]
}References
- https://github.com/shopware/shopware/security/advisories/GHSA-p523-jrph-qjc6
- https://nvd.nist.gov/vuln/detail/CVE-2022-21652
- https://github.com/shopware/shopware/commit/47ebd126a94f4b019b6fde64c0df3d18d74ef7d0
- https://docs.shopware.com/en/shopware-5-en/securityupdates/security-update-01-2022
- https://github.com/shopware/shopware