GHSA-p4g7-wjhq-9r2hmedium6.1
PayPal PHP Merchant SDK Cross-site scripting (XSS) vulnerability
The advisory, in context
Cross-site scripting (XSS) vulnerability in GetAuthDetails.html.php in PayPal PHP Merchant SDK (aka merchant-sdk-php) 3.9.1 allows remote attackers to inject arbitrary web script or HTML via the token parameter.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
paypal/merchant-sdk-php Packagist
Ecosystem versions
From 3.0.0 before 3.12.0
Fixed in 3.12.0
9 explicitly affected versions
v3.10.0, v3.11.0, v3.4.102, v3.5.103, v3.6.106, v3.8.106, v3.8.107, v3.9.0, v3.9.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.0.0"
},
{
"fixed": "3.12.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.10.0",
"v3.11.0",
"v3.4.102",
"v3.5.103",
"v3.6.106",
"v3.8.106",
"v3.8.107",
"v3.9.0",
"v3.9.1"
]
}