Cross-Site Scripting in Bootstrap Package
The advisory, in context
Problem
It has been discovered that rendering content in the website frontend is vulnerable to cross-site scripting. A valid backend user account is needed to exploit this vulnerability.
The following templates are affected by the vulnerability:
Resources/Private/Partials/ContentElements/Carousel/Item/CallToAction.htmlResources/Private/Partials/ContentElements/Carousel/Item/Header.htmlResources/Private/Partials/ContentElements/Carousel/Item/Text.htmlResources/Private/Partials/ContentElements/Carousel/Item/TextAndImage.htmlResources/Private/Partials/ContentElements/Header/SubHeader.html
Users of the extension, who have overwritten the affected templates with custom code must manually apply the security fix as shown in this Git commit.
Solution
Update to version 7.1.2, 8.0.8, 9.0.4, 9.1.3, 10.0.10 or 11.0.3 of the Bootstrap Package that fix the problem described.
Updated version are available from the TYPO3 extension manager, Packagist and at https://extensions.typo3.org/extension/download/bootstrap_package/.
Credits
Thanks to TYPO3 security team member Oliver Hader who reported and fixed the issue.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 7.1.0 before 7.1.2
Fixed in 7.1.2
2 explicitly affected versions
7.1.0, 7.1.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "7.1.0"
},
{
"fixed": "7.1.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"7.1.0",
"7.1.1"
]
}From 8.0.0 before 8.0.8
Fixed in 8.0.8
8 explicitly affected versions
8.0.0, 8.0.1, 8.0.2, 8.0.3, 8.0.4, 8.0.5, 8.0.6, 8.0.7
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "8.0.0"
},
{
"fixed": "8.0.8"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"8.0.0",
"8.0.1",
"8.0.2",
"8.0.3",
"8.0.4",
"8.0.5",
"8.0.6",
"8.0.7"
]
}From 9.0.0 before 9.0.4
Fixed in 9.0.4
4 explicitly affected versions
9.0.0, 9.0.1, 9.0.2, 9.0.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "9.0.0"
},
{
"fixed": "9.0.4"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"9.0.0",
"9.0.1",
"9.0.2",
"9.0.3"
]
}From 9.1.0 before 9.1.3
Fixed in 9.1.3
3 explicitly affected versions
9.1.0, 9.1.1, 9.1.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "9.1.0"
},
{
"fixed": "9.1.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"9.1.0",
"9.1.1",
"9.1.2"
]
}From 10.0.0 before 10.0.10
Fixed in 10.0.10
10 explicitly affected versions
10.0.0, 10.0.1, 10.0.2, 10.0.3, 10.0.4, 10.0.5, 10.0.6, 10.0.7, 10.0.8, 10.0.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "10.0.0"
},
{
"fixed": "10.0.10"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"10.0.0",
"10.0.1",
"10.0.2",
"10.0.3",
"10.0.4",
"10.0.5",
"10.0.6",
"10.0.7",
"10.0.8",
"10.0.9"
]
}From 11.0.0 before 11.0.3
Fixed in 11.0.3
3 explicitly affected versions
11.0.0, 11.0.1, 11.0.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "11.0.0"
},
{
"fixed": "11.0.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"11.0.0",
"11.0.1",
"11.0.2"
]
}