Dolibarr Cross-site scripting (XSS) vulnerability
The advisory, in context
Cross-site scripting (XSS) vulnerability in Dolibarr before 7.0.2 allows remote attackers to inject arbitrary web script or HTML via the foruserlogin parameter to adherents/cartes/carte.php.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 7.0.2
Fixed in 7.0.2
60 explicitly affected versions
3.6.0, 3.6.0-beta, 3.6.1, 3.6.2, 3.6.3, 3.6.4, 3.6.5, 3.6.6, 3.7.0, 3.7.1, 3.7.2, 3.7.3, 3.7.4, 3.8.0, 3.8.0-beta, 3.8.1, 3.8.2, 3.8.3, 3.8.4, 3.9.0, 3.9.0-rc, 3.9.0-rc2, 3.9.1, 3.9.2, 3.9.3, 3.9.4, 4.0.0, 4.0.0-beta, 4.0.0-rc, 4.0.0-rc2, 4.0.1, 4.0.2, 4.0.3, 4.0.4, 4.0.5, 4.0.6, 5.0.0, 5.0.0-beta, 5.0.0-rc1, 5.0.0-rc2, 5.0.1, 5.0.2, 5.0.3, 5.0.4, 5.0.5, 5.0.6, 5.0.7, 6.0.0, 6.0.0-beta, 6.0.0-rc, 6.0.1, 6.0.2, 6.0.3, 6.0.4, 6.0.5, 6.0.6, 6.0.7, 6.0.8, 7.0.0, 7.0.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "7.0.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"3.6.0",
"3.6.0-beta",
"3.6.1",
"3.6.2",
"3.6.3",
"3.6.4",
"3.6.5",
"3.6.6",
"3.7.0",
"3.7.1",
"3.7.2",
"3.7.3",
"3.7.4",
"3.8.0",
"3.8.0-beta",
"3.8.1",
"3.8.2",
"3.8.3",
"3.8.4",
"3.9.0",
"3.9.0-rc",
"3.9.0-rc2",
"3.9.1",
"3.9.2",
"3.9.3",
"3.9.4",
"4.0.0",
"4.0.0-beta",
"4.0.0-rc",
"4.0.0-rc2",
"4.0.1",
"4.0.2",
"4.0.3",
"4.0.4",
"4.0.5",
"4.0.6",
"5.0.0",
"5.0.0-beta",
"5.0.0-rc1",
"5.0.0-rc2",
"5.0.1",
"5.0.2",
"5.0.3",
"5.0.4",
"5.0.5",
"5.0.6",
"5.0.7",
"6.0.0",
"6.0.0-beta",
"6.0.0-rc",
"6.0.1",
"6.0.2",
"6.0.3",
"6.0.4",
"6.0.5",
"6.0.6",
"6.0.7",
"6.0.8",
"7.0.0",
"7.0.1"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2018-10095
- https://github.com/Dolibarr/dolibarr/commit/1dc466e1fb687cfe647de4af891720419823ed56
- https://github.com/Dolibarr/dolibarr
- https://github.com/Dolibarr/dolibarr/blob/7.0.2/ChangeLog
- https://sysdream.com/news/lab/2018-05-21-cve-2018-10095-dolibarr-xss-injection-vulnerability
- http://www.openwall.com/lists/oss-security/2018/05/21/3