Converse.js Exposure of Sensitive Information
The advisory, in context
Converse.js and Inverse.js through 3.3 allow remote attackers to obtain sensitive information because it is too difficult to determine whether safe publication of private data was configured or even intended. For example, users might have an expectation that chatroom bookmarks are private, but the various interacting software components do not necessarily make that happen.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 3.3.3
Fixed in 3.3.3
14 explicitly affected versions
3.2.0-rc, 3.3.2, v2.0.5, v2.0.6, v3.0.0, v3.0.1, v3.0.2, v3.1.0, v3.1.1, v3.2.0, v3.2.1, v3.2.2, v3.3.0, v3.3.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "3.3.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"3.2.0-rc",
"3.3.2",
"v2.0.5",
"v2.0.6",
"v3.0.0",
"v3.0.1",
"v3.0.2",
"v3.1.0",
"v3.1.1",
"v3.2.0",
"v3.2.1",
"v3.2.2",
"v3.3.0",
"v3.3.1"
]
}Earlier releases before 3.3.3
Fixed in 3.3.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "3.3.3"
}
],
"type": "SEMVER"
}
],
"versions": []
}