libsodium has Incomplete List of Disallowed Inputs
The advisory, in context
libsodium before ad3004e, in atypical use cases involving certain custom cryptography or untrusted data to crypto_core_ed25519_is_valid_point, mishandles checks for whether an elliptic curve point is valid because it sometimes allows points that aren't in the main cryptographic group.
This advisoory lists packages in the GitHub Advisory Database's supported ecosystems that are affected by this vulnerability due to a vulnerable dependency.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 2 before 2.5.0
Fixed in 2.5.0
6 explicitly affected versions
v2.0.1, v2.1.0, v2.2.0, v2.3.0, v2.3.1, v2.4.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2"
},
{
"fixed": "2.5.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v2.0.1",
"v2.1.0",
"v2.2.0",
"v2.3.0",
"v2.3.1",
"v2.4.0"
]
}Earlier releases before 1.24.0
Fixed in 1.24.0
73 explicitly affected versions
v0.1.0, v0.1.1, v0.2.0, v0.2.1, v0.2.2, v0.3.0, v0.3.1, v0.4.0, v0.5.0, v0.6.0, v0.7.0, v0.8.0, v0.8.1, v1.0.0, v1.0.1, v1.1.0, v1.10.0, v1.10.1, v1.11.0, v1.11.1, v1.11.2, v1.11.3, v1.11.4, v1.12.0, v1.12.1, v1.12.2, v1.13.0, v1.14.0, v1.15.0, v1.15.1, v1.15.2, v1.15.3, v1.15.4, v1.16.0, v1.16.1, v1.17.0, v1.17.1, v1.18.0, v1.18.1, v1.19.0, v1.2.0, v1.20.0, v1.20.1, v1.21.0, v1.21.1, v1.21.2, v1.22.0, v1.23.0, v1.3.0, v1.3.1, v1.4.0, v1.5.0, v1.5.1, v1.5.2, v1.5.3, v1.5.4, v1.5.5, v1.5.6, v1.6.0, v1.6.1, v1.6.2, v1.6.3, v1.6.4, v1.6.5, v1.6.6, v1.7.0, v1.8.0, v1.8.1, v1.9.0, v1.9.1, v1.9.2, v1.9.3, v1.9.4
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.24.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v0.1.0",
"v0.1.1",
"v0.2.0",
"v0.2.1",
"v0.2.2",
"v0.3.0",
"v0.3.1",
"v0.4.0",
"v0.5.0",
"v0.6.0",
"v0.7.0",
"v0.8.0",
"v0.8.1",
"v1.0.0",
"v1.0.1",
"v1.1.0",
"v1.10.0",
"v1.10.1",
"v1.11.0",
"v1.11.1",
"v1.11.2",
"v1.11.3",
"v1.11.4",
"v1.12.0",
"v1.12.1",
"v1.12.2",
"v1.13.0",
"v1.14.0",
"v1.15.0",
"v1.15.1",
"v1.15.2",
"v1.15.3",
"v1.15.4",
"v1.16.0",
"v1.16.1",
"v1.17.0",
"v1.17.1",
"v1.18.0",
"v1.18.1",
"v1.19.0",
"v1.2.0",
"v1.20.0",
"v1.20.1",
"v1.21.0",
"v1.21.1",
"v1.21.2",
"v1.22.0",
"v1.23.0",
"v1.3.0",
"v1.3.1",
"v1.4.0",
"v1.5.0",
"v1.5.1",
"v1.5.2",
"v1.5.3",
"v1.5.4",
"v1.5.5",
"v1.5.6",
"v1.6.0",
"v1.6.1",
"v1.6.2",
"v1.6.3",
"v1.6.4",
"v1.6.5",
"v1.6.6",
"v1.7.0",
"v1.8.0",
"v1.8.1",
"v1.9.0",
"v1.9.1",
"v1.9.2",
"v1.9.3",
"v1.9.4"
]
}Earlier releases before 1.6.2
Fixed in 1.6.2
18 explicitly affected versions
0.1.0, 0.2.0, 0.2.1, 0.2.2, 0.2.3, 0.3.0, 1.0, 1.0.1, 1.1.0, 1.1.1, 1.1.2, 1.2.0, 1.2.1, 1.3.0, 1.4.0, 1.5.0, 1.6.0, 1.6.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.6.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"0.1.0",
"0.2.0",
"0.2.1",
"0.2.2",
"0.2.3",
"0.3.0",
"1.0",
"1.0.1",
"1.1.0",
"1.1.1",
"1.1.2",
"1.2.0",
"1.2.1",
"1.3.0",
"1.4.0",
"1.5.0",
"1.6.0",
"1.6.1"
]
}Earlier releases before 3.6.1
Fixed in 3.6.1
32 explicitly affected versions
0.1.0, 0.1.0a1, 0.1.1, 0.2.0, 1.0.0, 1.0.1, 1.1.0, 1.1.1, 1.2.0, 1.3.0, 1.3.1, 1.3.2, 2.0.0, 2.0.0a1, 2.0.1, 2.1.0, 2.1.1, 2.1.2, 2.2.0, 2.2.1, 3.0.0, 3.0.1, 3.1.0, 3.1.0b1, 3.1.0b2, 3.2.0, 3.2.1, 3.2.3, 3.3.0, 3.4.0, 3.5.1, 3.6.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "3.6.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"0.1.0",
"0.1.0a1",
"0.1.1",
"0.2.0",
"1.0.0",
"1.0.1",
"1.1.0",
"1.1.1",
"1.2.0",
"1.3.0",
"1.3.1",
"1.3.2",
"2.0.0",
"2.0.0a1",
"2.0.1",
"2.1.0",
"2.1.1",
"2.1.2",
"2.2.0",
"2.2.1",
"3.0.0",
"3.0.1",
"3.1.0",
"3.1.0b1",
"3.1.0b2",
"3.2.0",
"3.2.1",
"3.2.3",
"3.3.0",
"3.4.0",
"3.5.1",
"3.6.0"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2025-69277
- https://github.com/pyca/pynacl/issues/920
- https://github.com/hdwallet-io/python-hdwallet/pull/124
- https://github.com/jedisct1/libsodium/commit/ad3004ec8731730e93fcfbbc824e67eadc1c1bae
- https://github.com/paragonie/sodium_compat/commit/2cb48f26130919f92f30650bdcc30e6f4ebe45ac
- https://github.com/paragonie/sodium_compat/commit/4714da6efdc782c06690bc72ce34fae7941c2d9f
- https://github.com/pyca/pynacl/commit/96314884d88d1089ff5f336dba61d7abbcddbbf7
- https://github.com/pyca/pynacl/commit/ecf41f55a3d8f1e10ce89c61c4b4d67f3f4467cf
- https://00f.net/2025/12/30/libsodium-vulnerability
- https://github.com/FriendsOfPHP/security-advisories/blob/master/paragonie/sodium_compat/2025-12-30.yaml
- https://github.com/paragonie/sodium_compat
- https://ianix.com/pub/ed25519-deployment.html
- https://lists.debian.org/debian-lts-announce/2026/01/msg00004.html
- https://news.ycombinator.com/item?id=46435614