phpMyAdmin IPv6 and proxy server IP-based authentication rule circumvention
The advisory, in context
An issue was discovered in phpMyAdmin involving improper enforcement of the IP-based authentication rules. When phpMyAdmin is used with IPv6 in a proxy server environment, and the proxy server is in the allowed range but the attacking computer is not allowed, this vulnerability can allow the attacking computer to connect despite the IP rules. All 4.6.x versions (prior to 4.6.4), 4.4.x versions (prior to 4.4.15.8), and 4.0.x versions (prior to 4.0.10.17) are affected.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 4.6 before 4.6.4
Fixed in 4.6.4
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.6"
},
{
"fixed": "4.6.4"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}From 4.4 before 4.4.15.8
Fixed in 4.4.15.8
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.4"
},
{
"fixed": "4.4.15.8"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}From 4.0 before 4.0.10.17
Fixed in 4.0.10.17
22 explicitly affected versions
4.0.0, 4.0.1, 4.0.10, 4.0.10.1, 4.0.10.2, 4.0.10.3, 4.0.10.4, 4.0.10.5, 4.0.10.6, 4.0.10.7, 4.0.10.8, 4.0.10.9, 4.0.2, 4.0.3, 4.0.4, 4.0.4.1, 4.0.4.2, 4.0.5, 4.0.6, 4.0.7, 4.0.8, 4.0.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.0"
},
{
"fixed": "4.0.10.17"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"4.0.0",
"4.0.1",
"4.0.10",
"4.0.10.1",
"4.0.10.2",
"4.0.10.3",
"4.0.10.4",
"4.0.10.5",
"4.0.10.6",
"4.0.10.7",
"4.0.10.8",
"4.0.10.9",
"4.0.2",
"4.0.3",
"4.0.4",
"4.0.4.1",
"4.0.4.2",
"4.0.5",
"4.0.6",
"4.0.7",
"4.0.8",
"4.0.9"
]
}