GHSA-mhfv-8rc9-w38chigh
Arbitrary shell execution
No CVE assignedCheck your stack
The advisory, in context
Uses of shell_exec() and exec() were not escaping filenames and configuration settings in most cases
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
squizlabs/php_codesniffer Packagist
Ecosystem versions
From 1.0.0 before 2.8.1
Fixed in 2.8.1
41 explicitly affected versions
1.4.2, 1.4.3, 1.4.4, 1.4.5, 1.4.6, 1.4.7, 1.4.8, 1.5.0, 1.5.0RC1, 1.5.0RC2, 1.5.0RC3, 1.5.0RC4, 1.5.1, 1.5.2, 1.5.3, 1.5.4, 1.5.5, 1.5.6, 2.0.0, 2.0.0RC1, 2.0.0RC2, 2.0.0RC3, 2.0.0RC4, 2.0.0a1, 2.0.0a2, 2.1.0, 2.2.0, 2.3.0, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.4.0, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, 2.8.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.0.0"
},
{
"fixed": "2.8.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.4.2",
"1.4.3",
"1.4.4",
"1.4.5",
"1.4.6",
"1.4.7",
"1.4.8",
"1.5.0",
"1.5.0RC1",
"1.5.0RC2",
"1.5.0RC3",
"1.5.0RC4",
"1.5.1",
"1.5.2",
"1.5.3",
"1.5.4",
"1.5.5",
"1.5.6",
"2.0.0",
"2.0.0RC1",
"2.0.0RC2",
"2.0.0RC3",
"2.0.0RC4",
"2.0.0a1",
"2.0.0a2",
"2.1.0",
"2.2.0",
"2.3.0",
"2.3.1",
"2.3.2",
"2.3.3",
"2.3.4",
"2.4.0",
"2.5.0",
"2.5.1",
"2.6.0",
"2.6.1",
"2.6.2",
"2.7.0",
"2.7.1",
"2.8.0"
]
}