TinyMCE Cross-Site Scripting (XSS) vulnerability using sanitization bypass through nested SVGs
The advisory, in context
Impact
TinyMCE 6.8.x contains an XSS vulnerability caused by improper SVG namespace scope handling in the sanitizer. A crafted payload using nested <svg> elements can bypass attribute sanitization and execute arbitrary JavaScript.
Patches
This issue affects TinyMCE 6.8.x-7.0.x. The vulnerability is fixed in TinyMCE 7.1.0 and later.
Workarounds
No official workaround available.
Acknowledgements
Tiny thanks maple3142 (https://maple3142.net) of DEVCORE for their help identifying this vulnerability.
References
Fix introduced in TinyMCE 7.1.0 though a rewrite of code causing the vulnerability.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 6.8.0 before 7.1.0
Fixed in 7.1.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "6.8.0"
},
{
"fixed": "7.1.0"
}
],
"type": "SEMVER"
}
],
"versions": []
}From 6.8.0 before 7.1.0
Fixed in 7.1.0
9 explicitly affected versions
6.8.0, 6.8.1, 6.8.2, 6.8.3, 6.8.4, 6.8.5, 6.8.6, 7.0.0, 7.0.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "6.8.0"
},
{
"fixed": "7.1.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"6.8.0",
"6.8.1",
"6.8.2",
"6.8.3",
"6.8.4",
"6.8.5",
"6.8.6",
"7.0.0",
"7.0.1"
]
}From 6.8.0 before 7.1.0
Fixed in 7.1.0
9 explicitly affected versions
6.8.0, 6.8.1, 6.8.2, 6.8.3, 6.8.4, 6.8.5, 6.8.6, 7.0.0, 7.0.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "6.8.0"
},
{
"fixed": "7.1.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"6.8.0",
"6.8.1",
"6.8.2",
"6.8.3",
"6.8.4",
"6.8.5",
"6.8.6",
"7.0.0",
"7.0.1"
]
}