GHSA-m98q-q59p-r9fvmedium6.1
Moodle open redirect vulnerability
The advisory, in context
A vulnerability was found in Moodle 3.7 to 3.7.3, 3.6 to 3.6.7, 3.5 to 3.5.9 and earlier where an open redirect existed in the Lesson edit page.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
moodle/moodle Packagist
Ecosystem versions
From 3.5 before 3.5.9
Fixed in 3.5.9
11 explicitly affected versions
v3.5.0, v3.5.0-beta, v3.5.0-rc1, v3.5.1, v3.5.2, v3.5.3, v3.5.4, v3.5.5, v3.5.6, v3.5.7, v3.5.8
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.5"
},
{
"fixed": "3.5.9"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.5.0",
"v3.5.0-beta",
"v3.5.0-rc1",
"v3.5.1",
"v3.5.2",
"v3.5.3",
"v3.5.4",
"v3.5.5",
"v3.5.6",
"v3.5.7",
"v3.5.8"
]
}moodle/moodle Packagist
Ecosystem versions
From 3.6 before 3.6.7
Fixed in 3.6.7
11 explicitly affected versions
v3.6.0, v3.6.0-beta, v3.6.0-rc1, v3.6.0-rc2, v3.6.0-rc3, v3.6.1, v3.6.2, v3.6.3, v3.6.4, v3.6.5, v3.6.6
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.6"
},
{
"fixed": "3.6.7"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.6.0",
"v3.6.0-beta",
"v3.6.0-rc1",
"v3.6.0-rc2",
"v3.6.0-rc3",
"v3.6.1",
"v3.6.2",
"v3.6.3",
"v3.6.4",
"v3.6.5",
"v3.6.6"
]
}moodle/moodle Packagist
Ecosystem versions
From 3.7 before 3.7.3
Fixed in 3.7.3
6 explicitly affected versions
v3.7.0, v3.7.0-beta, v3.7.0-rc1, v3.7.0-rc2, v3.7.1, v3.7.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.7"
},
{
"fixed": "3.7.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.7.0",
"v3.7.0-beta",
"v3.7.0-rc1",
"v3.7.0-rc2",
"v3.7.1",
"v3.7.2"
]
}