GHSA-m983-q76g-cwpqhigh7.5
Gravity Forms plugin leak hashed passwords
The advisory, in context
common.php in the Gravity Forms plugin before 2.4.9 for WordPress can leak hashed passwords because user_pass is not considered a special case for a $current_user->get($property) call.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
wp-premium/gravityforms Packagist
Ecosystem versions
Earlier releases before 2.4.9
Fixed in 2.4.9
5 explicitly affected versions
2.2.6.5, 2.3.2, 2.4.5, 2.4.7.3, 2.4.8
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "2.4.9"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.2.6.5",
"2.3.2",
"2.4.5",
"2.4.7.3",
"2.4.8"
]
}