GHSA-m8xh-cqc2-5q6fcritical9.8
Type Confusion in ImpressCMS
The advisory, in context
ImpressCMS before 1.4.3 has plugins/preloads/autologin.php type confusion with resultant Authentication Bypass (!= instead of !==).
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
impresscms/impresscms Packagist
Ecosystem versions
Earlier releases before 1.4.3
Fixed in 1.4.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.4.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}References
- https://nvd.nist.gov/vuln/detail/CVE-2021-26600
- https://hackerone.com/reports/1081986
- https://github.com/ImpressCMS/impresscms
- https://github.com/ImpressCMS/impresscms/releases/tag/v1.4.3
- http://karmainsecurity.com/KIS-2022-01
- http://packetstormsecurity.com/files/166393/ImpressCMS-1.4.2-Authentication-Bypass.html
- http://seclists.org/fulldisclosure/2022/Mar/43