GHSA-m899-6mh4-mpc5high7.2
MODX Revolution Incorrect Access Control vulnerability
The advisory, in context
MODX Revolution version <=2.6.4 contains a Incorrect Access Control vulnerability in Filtering user parameters before passing them into phpthumb class that can result in Creating file with custom a filename and content. This attack appear to be exploitable via Web request. This vulnerability appears to have been fixed in commit 06bc94257408f6a575de20ddb955aca505ef6e68.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
modx/revolution Packagist
Ecosystem versions
Earlier releases before 2.7.0
Fixed in 2.7.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "2.7.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}References
- https://nvd.nist.gov/vuln/detail/CVE-2018-1000207
- https://github.com/modxcms/revolution/pull/13979
- https://github.com/modxcms/revolution/commit/06bc94257408f6a575de20ddb955aca505ef6e68
- https://github.com/a2u/CVE-2018-1000207
- https://github.com/modxcms/revolution
- https://rudnkh.me/posts/critical-vulnerability-in-modx-revolution-2-6-4