BuddyPress privilege escalation via REST API
The advisory, in context
Impact
It's possible for a non-privileged, regular user to obtain administrator rights by exploiting an issue in the BuddyPress REST API members endpoint.
Patches
The vulnerability has been fixed in BuddyPress 7.2.1. Existing installations of the plugin should be updated to this version to mitigate the issue.
References
https://buddypress.org/2021/03/buddypress-7-2-1-security-release/
For more information
If you have any questions or comments about this advisory:
- Open an issue in HackerOne
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 5.0.0 before 7.2.1
Fixed in 7.2.1
27 explicitly affected versions
5.0.0, 5.1.0, 5.1.0-beta1, 5.1.1, 5.1.2, 5.2.0, 5.2.1, 5.2.2, 6.0.0, 6.0.0-RC1, 6.0.0-RC2, 6.0.0-beta1, 6.0.0-beta2, 6.1.0, 6.2.0, 6.2.0-beta1, 6.3.0, 6.4.0, 6.4.2, 6.4.3, 7.0.0, 7.0.0-RC1, 7.0.0-RC2, 7.0.0-beta1, 7.0.0-beta2, 7.1.0, 7.2.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "5.0.0"
},
{
"fixed": "7.2.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"5.0.0",
"5.1.0",
"5.1.0-beta1",
"5.1.1",
"5.1.2",
"5.2.0",
"5.2.1",
"5.2.2",
"6.0.0",
"6.0.0-RC1",
"6.0.0-RC2",
"6.0.0-beta1",
"6.0.0-beta2",
"6.1.0",
"6.2.0",
"6.2.0-beta1",
"6.3.0",
"6.4.0",
"6.4.2",
"6.4.3",
"7.0.0",
"7.0.0-RC1",
"7.0.0-RC2",
"7.0.0-beta1",
"7.0.0-beta2",
"7.1.0",
"7.2.0"
]
}