GHSA-m5vv-7jxc-8p6xmedium5.3
Redaxo Core CMS Cross Site Scripting (XSS)
The advisory, in context
The mediapool feature of the Redaxo Core CMS application v 5.17.1 is vulnerable to Cross Site Scripting(XSS) which allows a remote attacker to escalate privileges.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
redaxo/source Packagist
Ecosystem versions
Earlier releases before 5.18.0
Fixed in 5.18.0
33 explicitly affected versions
5.10.0, 5.10.0-beta1, 5.10.0-beta2, 5.10.1, 5.11.0, 5.11.0-beta1, 5.11.1, 5.11.2, 5.12.0, 5.12.0-beta1, 5.12.0-beta2, 5.12.0-beta3, 5.12.1, 5.13.0, 5.13.0-beta1, 5.13.0-beta2, 5.13.1, 5.13.2, 5.13.3, 5.14.0, 5.14.0-beta1, 5.14.0-beta2, 5.14.1, 5.14.2, 5.14.3, 5.15.0, 5.15.0-beta1, 5.15.1, 5.16.0, 5.16.0-beta1, 5.16.1, 5.17.0, 5.17.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "5.18.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"5.10.0",
"5.10.0-beta1",
"5.10.0-beta2",
"5.10.1",
"5.11.0",
"5.11.0-beta1",
"5.11.1",
"5.11.2",
"5.12.0",
"5.12.0-beta1",
"5.12.0-beta2",
"5.12.0-beta3",
"5.12.1",
"5.13.0",
"5.13.0-beta1",
"5.13.0-beta2",
"5.13.1",
"5.13.2",
"5.13.3",
"5.14.0",
"5.14.0-beta1",
"5.14.0-beta2",
"5.14.1",
"5.14.2",
"5.14.3",
"5.15.0",
"5.15.0-beta1",
"5.15.1",
"5.16.0",
"5.16.0-beta1",
"5.16.1",
"5.17.0",
"5.17.1"
]
}