Missing Required Cryptographic Step Leading to Sensitive Information Disclosure in TYPO3 CMS
Impact
> Meta > CVSS: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H/E:F/RL:O/RC:C (8.2) > CWE-325, CWE-20, CWE-200, CWE-502
Source excerpt · OSV- TYPO3-CORE-SA-2020-007, CVE-2020-15099: Potential Privilege Escalation
- the database server used for a TYPO3 installation must be accessible for an attacker (either via internet or shared hosting network)
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:F/RL:O/RC:C(7.5, high)
- TYPO3-CORE-SA-2016-013, CVE-2016-5091: Insecure Deserialization & Remote Code Execution
- an attacker must have access to at least one Extbase plugin or module action in a TYPO3 installation
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:F/RL:O/RC:C(9.1, critical)
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
| Affected range | Recorded fix |
|---|---|
| From 9.0.0 before 9.5.20Ecosystem versions | 9.5.20 |
| From 10.0.0 before 10.4.6Ecosystem versions | 10.4.6 |
Version evidence: OSV · GHSA-m5vr-3m74-jwxp
View original version evidence (41 explicit versions)
| Affected range | Recorded fix |
|---|---|
| From 10.0.0 before 10.4.6Ecosystem versions | 10.4.6 |
| From 9.0.0 before 9.5.20Ecosystem versions | 9.5.20 |
Version evidence: OSV · GHSA-m5vr-3m74-jwxp
View original version evidence (41 explicit versions)
Original source description
Meta
- CVSS:
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H/E:F/RL:O/RC:C(8.2)- CWE-325, CWE-20, CWE-200, CWE-502
Problem
It has been discovered that an internal verification mechanism can be used to generate arbitrary checksums. This allows to inject arbitrary data having a valid cryptographic message authentication code (HMAC-SHA1) and can lead to various attack chains as described below.
- TYPO3-CORE-SA-2020-007, CVE-2020-15099: Potential Privilege Escalation
- the database server used for a TYPO3 installation must be accessible for an attacker (either via internet or shared hosting network)
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:F/RL:O/RC:C(7.5, high)
- TYPO3-CORE-SA-2016-013, CVE-2016-5091: Insecure Deserialization & Remote Code Execution
- an attacker must have access to at least one Extbase plugin or module action in a TYPO3 installation
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:F/RL:O/RC:C(9.1, critical)
The overall severity of this vulnerability is high (8.2) based on mentioned attack chains and the requirement of having a valid backend user session (authenticated).
Solution
Update to TYPO3 versions 9.5.20 or 10.4.6 that fix the problem described.
Credits
Thanks to TYPO3 security team member Oliver Hader who reported and fixed the issue.
References
References
- Security advisory github.com/TYPO3/TYPO3.CMS/security/advisories/GHSA-m5vr-3m74-jwxp
- Security advisory nvd.nist.gov/vuln/detail/CVE-2016-5091
- Security advisory nvd.nist.gov/vuln/detail/CVE-2020-15098
- Patch github.com/TYPO3/TYPO3.CMS/commit/85d3e70dff35a99ef53f4b561114acfa9e5c47e1
- Security advisory github.com/FriendsOfPHP/security-advisories/blob/master/typo3/cms-core/CVE-2020-15098.yaml
- Security advisory github.com/FriendsOfPHP/security-advisories/blob/master/typo3/cms/CVE-2020-15098.yaml
- Source reference github.com/TYPO3/TYPO3.CMS
- Security advisory typo3.org/security/advisory/typo3-core-sa-2016-013
- Security advisory typo3.org/security/advisory/typo3-core-sa-2020-008