Pimcore Cross-site Scripting (XSS) vulnerability
The advisory, in context
bundles/AdminBundle/Controller/Admin/EmailController.php in Pimcore before 6.3.0 allows script execution in the Email Log preview window because of the lack of a Content-Security-Policy header.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 6.3.0
Fixed in 6.3.0
94 explicitly affected versions
2.2.0, 2.2.1, 2.2.2, 2.3.0, 3.0.0, 3.0.1, 3.0.2, 3.0.3, 3.0.4, 3.0.5, 3.0.6, 3.1.0, 3.1.1, 4.0.0, 4.0.1, 4.1.0, 4.1.1, 4.1.2, 4.1.3, 4.2.0, 4.3.0, 4.3.1, 4.4.0, 4.4.1, 4.4.2, 4.4.3, 4.5.0, 4.6.0, 4.6.1, 4.6.2, 4.6.3, 4.6.4, 4.6.5, v5.0.0, v5.0.0-RC, v5.0.1, v5.0.2, v5.0.3, v5.0.4, v5.1.0, v5.1.0-alpha, v5.1.1, v5.1.2, v5.1.3, v5.2.0, v5.2.1, v5.2.2, v5.2.3, v5.3.0, v5.3.1, v5.4.0, v5.4.1, v5.4.2, v5.4.3, v5.4.4, v5.5.0, v5.5.1, v5.5.2, v5.5.3, v5.5.4, v5.6.0, v5.6.1, v5.6.2, v5.6.3, v5.6.4, v5.6.5, v5.6.6, v5.7.0, v5.7.1, v5.7.2, v5.7.3, v5.8.0, v5.8.1, v5.8.2, v5.8.3, v5.8.4, v5.8.5, v5.8.6, v5.8.7, v5.8.8, v5.8.9, v6.0.0, v6.0.1, v6.0.2, v6.0.3, v6.0.4, v6.0.5, v6.1.0, v6.1.1, v6.1.2, v6.2.0, v6.2.1, v6.2.2, v6.2.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "6.3.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.2.0",
"2.2.1",
"2.2.2",
"2.3.0",
"3.0.0",
"3.0.1",
"3.0.2",
"3.0.3",
"3.0.4",
"3.0.5",
"3.0.6",
"3.1.0",
"3.1.1",
"4.0.0",
"4.0.1",
"4.1.0",
"4.1.1",
"4.1.2",
"4.1.3",
"4.2.0",
"4.3.0",
"4.3.1",
"4.4.0",
"4.4.1",
"4.4.2",
"4.4.3",
"4.5.0",
"4.6.0",
"4.6.1",
"4.6.2",
"4.6.3",
"4.6.4",
"4.6.5",
"v5.0.0",
"v5.0.0-RC",
"v5.0.1",
"v5.0.2",
"v5.0.3",
"v5.0.4",
"v5.1.0",
"v5.1.0-alpha",
"v5.1.1",
"v5.1.2",
"v5.1.3",
"v5.2.0",
"v5.2.1",
"v5.2.2",
"v5.2.3",
"v5.3.0",
"v5.3.1",
"v5.4.0",
"v5.4.1",
"v5.4.2",
"v5.4.3",
"v5.4.4",
"v5.5.0",
"v5.5.1",
"v5.5.2",
"v5.5.3",
"v5.5.4",
"v5.6.0",
"v5.6.1",
"v5.6.2",
"v5.6.3",
"v5.6.4",
"v5.6.5",
"v5.6.6",
"v5.7.0",
"v5.7.1",
"v5.7.2",
"v5.7.3",
"v5.8.0",
"v5.8.1",
"v5.8.2",
"v5.8.3",
"v5.8.4",
"v5.8.5",
"v5.8.6",
"v5.8.7",
"v5.8.8",
"v5.8.9",
"v6.0.0",
"v6.0.1",
"v6.0.2",
"v6.0.3",
"v6.0.4",
"v6.0.5",
"v6.1.0",
"v6.1.1",
"v6.1.2",
"v6.2.0",
"v6.2.1",
"v6.2.2",
"v6.2.3"
]
}