Insufficient user authorization in Moodle
The advisory, in context
A flaw was found in Moodle in versions 3.11 to 3.11.4, 3.10 to 3.10.8, 3.9 to 3.9.11 and earlier unsupported versions. The calendar:manageentries capability allowed managers to access or modify any calendar event, but should have been restricted from accessing user level events.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 3.11 before 3.11.5
Fixed in 3.11.5
8 explicitly affected versions
v3.11.0, v3.11.0-beta, v3.11.0-rc1, v3.11.0-rc2, v3.11.1, v3.11.2, v3.11.3, v3.11.4
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.11"
},
{
"fixed": "3.11.5"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.11.0",
"v3.11.0-beta",
"v3.11.0-rc1",
"v3.11.0-rc2",
"v3.11.1",
"v3.11.2",
"v3.11.3",
"v3.11.4"
]
}From 3.10 before 3.10.8
Fixed in 3.10.8
11 explicitly affected versions
v3.10.0, v3.10.0-beta, v3.10.0-rc1, v3.10.0-rc2, v3.10.1, v3.10.2, v3.10.3, v3.10.4, v3.10.5, v3.10.6, v3.10.7
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.10"
},
{
"fixed": "3.10.8"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.10.0",
"v3.10.0-beta",
"v3.10.0-rc1",
"v3.10.0-rc2",
"v3.10.1",
"v3.10.2",
"v3.10.3",
"v3.10.4",
"v3.10.5",
"v3.10.6",
"v3.10.7"
]
}From 3.9 before 3.9.11
Fixed in 3.9.11
15 explicitly affected versions
v3.9.0, v3.9.0-beta, v3.9.0-rc1, v3.9.0-rc2, v3.9.0-rc3, v3.9.1, v3.9.10, v3.9.2, v3.9.3, v3.9.4, v3.9.5, v3.9.6, v3.9.7, v3.9.8, v3.9.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.9"
},
{
"fixed": "3.9.11"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.9.0",
"v3.9.0-beta",
"v3.9.0-rc1",
"v3.9.0-rc2",
"v3.9.0-rc3",
"v3.9.1",
"v3.9.10",
"v3.9.2",
"v3.9.3",
"v3.9.4",
"v3.9.5",
"v3.9.6",
"v3.9.7",
"v3.9.8",
"v3.9.9"
]
}